summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-10 07:20:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-10 07:25:12 +0100
commit20eadc3d80cd45ea015e3af2c09cb9fcb2432d41 (patch)
treeacecb6a6c37d66b0248cb3dea47b31f0ea4de466 /dev-python/jaraco-collections
parentdev-python/bitarray: Bump to 2.8.5 (diff)
downloadgentoo-20eadc3d80cd45ea015e3af2c09cb9fcb2432d41.tar.gz
gentoo-20eadc3d80cd45ea015e3af2c09cb9fcb2432d41.tar.bz2
gentoo-20eadc3d80cd45ea015e3af2c09cb9fcb2432d41.zip
dev-python/jaraco-collections: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-5.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index ddd3686f4d04..cd80eb0fdf5d 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-4.3.0.tar.gz 17862 BLAKE2B f40c6f40fb7fea5c74244b24a8121471ce4e33615d6db7f0db660f669c8aca65f9fb1986d2213762883b671067c8137c21694e41e7276cd4a9b00bc1989f022d SHA512 cee6169dfbe71752e6ed93db35a41896d891932cab949fed534bb90d5ac246eba3fb19105d39981b5cff9996331914e67858cc1158c23ffa702cf1cdcdced90e
+DIST jaraco.collections-5.0.0.tar.gz 17852 BLAKE2B 2ba362417835faea2f3ebfb24c8eeac2b302c64d2f653cf820f16218b5ae92aff270a14680ecee82847f65338d1dafbf9951e92f5874e7df79fd27918d9a2456 SHA512 bc4bf9159c3f2878fb3ed57e311c894986fa106af96423a612f25dbefb51f8dfc77fa1468612a224fbe26c64270745ff1c1db7d05d7c3f5d51040a8773298a73
diff --git a/dev-python/jaraco-collections/jaraco-collections-5.0.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-5.0.0.ebuild
new file mode 100644
index 000000000000..7705f0888340
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-5.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}