summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-28 08:57:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-28 09:02:13 +0200
commitd1a814030d453b4f759b1353c5f6e61b7089827e (patch)
tree86555df5d5ee829517c7c60f3711a32df54655f1 /dev-python/jaraco-logging
parentdev-python/zope-hookable: arm64 stable wrt bug #847775 (diff)
downloadgentoo-d1a814030d453b4f759b1353c5f6e61b7089827e.tar.gz
gentoo-d1a814030d453b4f759b1353c5f6e61b7089827e.tar.bz2
gentoo-d1a814030d453b4f759b1353c5f6e61b7089827e.zip
dev-python/jaraco-logging: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
deleted file mode 100644
index 9a25e08b7941..000000000000
--- a/dev-python/jaraco-logging/jaraco-logging-3.1.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
-HOMEPAGE="https://github.com/jaraco/jaraco.logging"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/tempora[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
- '>=dev-python/rst-linker-1.9'
-distutils_enable_tests pytest
-
-python_test() {
- # Override pytest options to skip flake8
- local -x PYTHONPATH=.
- epytest --override-ini="addopts=--doctest-modules"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}