summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-20 09:12:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-20 10:54:38 +0100
commit23c760d8d40f63e8ca69533f8072cb760645ca2d (patch)
treec108104cd45282a89082036bddeeb83f7c7d8e6e /dev-python/jeepney/jeepney-0.6.0.ebuild
parentdev-util/abi-dumper: Bump to 1.2 (diff)
downloadgentoo-23c760d8d40f63e8ca69533f8072cb760645ca2d.tar.gz
gentoo-23c760d8d40f63e8ca69533f8072cb760645ca2d.tar.bz2
gentoo-23c760d8d40f63e8ca69533f8072cb760645ca2d.zip
dev-python/jeepney: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jeepney/jeepney-0.6.0.ebuild')
-rw-r--r--dev-python/jeepney/jeepney-0.6.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jeepney/jeepney-0.6.0.ebuild b/dev-python/jeepney/jeepney-0.6.0.ebuild
new file mode 100644
index 000000000000..1c412f4100c2
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ rm jeepney/io/tests/test_trio.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}