summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/json-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/json-tools')
-rw-r--r--dev-python/json-tools/Manifest2
-rw-r--r--dev-python/json-tools/json-tools-0.3.3.ebuild30
-rw-r--r--dev-python/json-tools/json-tools-0.4.0.ebuild32
-rw-r--r--dev-python/json-tools/metadata.xml9
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/json-tools/Manifest b/dev-python/json-tools/Manifest
new file mode 100644
index 000000000000..9590204d8513
--- /dev/null
+++ b/dev-python/json-tools/Manifest
@@ -0,0 +1,2 @@
+DIST json_tools-0.3.3.tar.gz 8093 SHA256 d651d10326447b7a039305661b0fa6c44bb54ca2313494e20dda1e4c8c63b7d6 SHA512 34bb34d52f7f230a13071a9a5c3de79f2c76de6b4a8ce60d0acb4447f68893faeb79ee9a98133ba72f1c1acebd9e8beb34dba0953242aee97799e8b97fcf6537 WHIRLPOOL 203666696b13d95b4c918c604c8b968ac1b64603f3559fec4251c2d80792c1d0674fd7a7a086e4536110f241c93fe28457921023183daa3697bf7deee352a11f
+DIST json_tools-0.4.0.tar.gz 7277 SHA256 ec704468805d898da89c5c88157e8aa6559df0cfdcf29ed60a1076a45f79d19a SHA512 b3f86493d17f97eeaecec6572adfc6e16c113c1755f49655863e84f17467c9dae9a57911d66639eb6e6d8548a99887adc827ff28bd26b6180e523b145bba2d5b WHIRLPOOL aaac4a58404a77043cd977c198b5ffe71ec9be9fe0a7fb727bd2efb94802861b961355ce52c0b515456c404a3c855d5a38d4c15a9d9e03cdd9fb4d8bb4989cc5
diff --git a/dev-python/json-tools/json-tools-0.3.3.ebuild b/dev-python/json-tools/json-tools-0.3.3.ebuild
new file mode 100644
index 000000000000..582d0cd73c72
--- /dev/null
+++ b/dev-python/json-tools/json-tools-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+MY_PN="json_tools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A set of tools to manipulate JSON: diff, patch, and pretty-printing"
+HOMEPAGE="https://pypi.python.org/pypi/json_tools https://bitbucket.org/vadim_semenov/json_tools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/json-tools/json-tools-0.4.0.ebuild b/dev-python/json-tools/json-tools-0.4.0.ebuild
new file mode 100644
index 000000000000..4b5d1f103220
--- /dev/null
+++ b/dev-python/json-tools/json-tools-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# 'Programming Language :: ... in setup.py requires updating"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+MY_PN="json_tools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A set of tools to manipulate JSON: diff, patch, and pretty-printing"
+HOMEPAGE="https://pypi.python.org/pypi/json_tools https://bitbucket.org/vadim_semenov/json_tools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/json-tools/metadata.xml b/dev-python/json-tools/metadata.xml
new file mode 100644
index 000000000000..3212f3c37437
--- /dev/null
+++ b/dev-python/json-tools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">json_tools</remote-id>
+ <remote-id type="bitbucket">vadim_semenov/json_tools</remote-id>
+ </upstream>
+</pkgmetadata>