summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-02 19:17:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-02 19:17:19 +0300
commitd9503d461972f23b605f9694889b128748212116 (patch)
tree9a7177126a53f8a0ae94fba35e5b1e398bf3dbc5 /dev-python/json5
parentdev-python/yarl: add 1.8.1 (diff)
downloadgentoo-d9503d461972f23b605f9694889b128748212116.tar.gz
gentoo-d9503d461972f23b605f9694889b128748212116.tar.bz2
gentoo-d9503d461972f23b605f9694889b128748212116.zip
dev-python/json5: add 0.9.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/json5')
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.9.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index 20f98e062bfb..b806c67b195c 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1 +1,2 @@
DIST pyjson5-0.9.8.gh.tar.gz 110629 BLAKE2B 7a2acfbf1228e8f143a19775750e6d020376d63b2b036eac75be032b7baed1e6b93ea3ee842b0c200db6f44dc0f16f3c6c2f18cb165b24918334a48f237f2a9f SHA512 e1fb7a7457bdc68c33e2d73ddae8913aeec6f001e25a70234f7233d8d28b8eee8dd023c76e26dec0d0a2051e8e2cd731044dbe7dc15af9ec95f0ce806fabac72
+DIST pyjson5-0.9.9.gh.tar.gz 111214 BLAKE2B ccf329ea148e576655b1fb24124c813d31e117291cdfc53affa02542330b11c136cd28e74418351a30478249c8f4c109be6547d69e423c8c7b5f96f77ef5daac SHA512 cd28c64708738484376a03908ec75b30bee44a8834a1e9dbe81be98a6f46ba75600d6f958c6298998f373125589209907f5e8b63714ed6a83bb7a1d27adbccd5
diff --git a/dev-python/json5/json5-0.9.9.ebuild b/dev-python/json5/json5-0.9.9.ebuild
new file mode 100644
index 000000000000..0a10cb1d1bee
--- /dev/null
+++ b/dev-python/json5/json5-0.9.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest