summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 09:21:46 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 09:24:46 +0200
commit81f0c27b72506210f44ca0803bdca1b7addfec03 (patch)
tree93424290ab984bf1c64eeb2418c134c40e1abcaf /dev-python/jsonrpclib
parentdev-python/jsonrpclib: Drop old (diff)
downloadgentoo-81f0c27b72506210f44ca0803bdca1b7addfec03.tar.gz
gentoo-81f0c27b72506210f44ca0803bdca1b7addfec03.tar.bz2
gentoo-81f0c27b72506210f44ca0803bdca1b7addfec03.zip
dev-python/jsonrpclib: Bump to 0.4.0, py3.7, cleanup
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/Manifest1
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
index 5e6217890710..e236daa17abd 100644
--- a/dev-python/jsonrpclib/Manifest
+++ b/dev-python/jsonrpclib/Manifest
@@ -1 +1,2 @@
DIST jsonrpclib-0.3.1.tar.gz 42704 BLAKE2B e3c83bb25ec83a93fdde8f6f4b8b18de0d0ddd0cc35c04f9f83b1f0e75803211a6f6b85768b0c7f9de4bcac18df721df8057148aa7aa0628dd1d345c2e4d90e1 SHA512 7cd44d44f3952ee7ac4006904427ddd3a69b60e6a0a4eaff4b75d03b1c30f7a65debd69552035a4ee375a33c80ec428fc1ef10979f55316bcfd015603c62304f
+DIST jsonrpclib-0.4.0.tar.gz 57944 BLAKE2B 3458aee2dc27980ef93d7ae650f7d7485983598c8276f08b104a5b44d5dfb8f6225ba649dc7f6537fa66f6ba86d7082e11e23c7ca051c876a96d1b25efa4fa0e SHA512 357743e34447cd6dbe330c5adfa5541134a0ff8d82549ec47ed741ddf54a7aabb8cd417c501cb9ab814ce2cb90e1c2d4d4f21daac3b379f38be03c38a7ed198b
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild
new file mode 100644
index 000000000000..c7b359ea5372
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}