summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 07:27:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 09:48:14 +0200
commit99a81b41f812ed3b51d05dd408a5026314d52e3b (patch)
tree0119943ce1e57d8764b23ab77bf685bc4a7c187c /dev-python/jupyter_core
parentdev-python/fsspec: Bump to 2022.10.0 (diff)
downloadgentoo-99a81b41f812ed3b51d05dd408a5026314d52e3b.tar.gz
gentoo-99a81b41f812ed3b51d05dd408a5026314d52e3b.tar.bz2
gentoo-99a81b41f812ed3b51d05dd408a5026314d52e3b.zip
dev-python/jupyter_core: Bump to 4.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.11.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index f90a041f7cb7..5a3de0215dd9 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.11.1.tar.gz 73661 BLAKE2B 38f93826fd86f5b4dcd5495473426e934365aea3156e6bd881041920b5604a7ae11becc3d1037785f448f085b03e5afa361b7221378425e9e758fca90ed850e4 SHA512 38348e8fc349ab7bdc83599607e6179c2d14dd3a42daf6b52cb0a6fb4feee360aed4e7c682e6349dcf560b2dec598f9a27477e0b2e982fd85e5a385b1bca5858
+DIST jupyter_core-4.11.2.tar.gz 788994 BLAKE2B a337d6974f905b3b666225f828f2026f7dd314e34411f7998b8d2981ad9623029901e5369bfe831ecfcbf3be387bb0adc7f067269537a6b2a73029f439bfe9a1 SHA512 7659b61ad5793d6e4ceba09f7d4422610ceb358cbba30e2bee7ab7910e6c03cb365fad5db8e4444f9e0fd196361d5b15370f41fb7cb13c2e551382e19d7d6b73
diff --git a/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild b/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
new file mode 100644
index 000000000000..f7de21236410
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest