summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Payno <vpayno+gentoo@gmail.com>2020-04-13 15:22:25 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-25 20:11:48 -0700
commit9bc13a27c23fbfd5cf80c9fe6b96d22ba99abd4b (patch)
tree92188db9ab59493edca4e70591e83d4dc94df539 /dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
parentdev-python/versioneer-0.18-r1: add Python 3.8 (diff)
downloadgentoo-9bc13a27c23fbfd5cf80c9fe6b96d22ba99abd4b.tar.gz
gentoo-9bc13a27c23fbfd5cf80c9fe6b96d22ba99abd4b.tar.bz2
gentoo-9bc13a27c23fbfd5cf80c9fe6b96d22ba99abd4b.zip
dev-python/kiwisolver: Bump to version 1.2.0
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/kiwisolver/kiwisolver-1.2.0.ebuild')
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild b/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
new file mode 100644
index 000000000000..fd71991237c0
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/kiwi-${PV}
+
+distutils_enable_tests pytest