summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-03 17:46:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 18:27:18 +0200
commit190c1966f4268f731d697c49a52e1c0144ab413f (patch)
treef43faf1ed91cda323a5fe753dd9fb997a4cee7b4 /dev-python/libpillowfight
parentdev-python/libpillowfight: Enable py3.12 (diff)
downloadgentoo-190c1966f4268f731d697c49a52e1c0144ab413f.tar.gz
gentoo-190c1966f4268f731d697c49a52e1c0144ab413f.tar.bz2
gentoo-190c1966f4268f731d697c49a52e1c0144ab413f.zip
dev-python/libpillowfight: Simplify test logic
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libpillowfight')
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.3.0_p20210816-r1.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816-r1.ebuild b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816-r1.ebuild
index fa61cfd2453e..729c78ebf43d 100644
--- a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816-r1.ebuild
+++ b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816-r1.ebuild
@@ -27,7 +27,6 @@ RDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
- ln -s "${S}"/tests "${T}"/tests || die
sed -e "/'nose>=1.0'/d" -i setup.py || die
cat > src/pillowfight/_version.h <<- EOF || die
#define INTERNAL_PILLOWFIGHT_VERSION "$(ver_cut 1-3)"
@@ -36,6 +35,5 @@ python_prepare_all() {
}
python_test() {
- cd "${T}" || die
- epytest "${S}"/tests -o addopts=
+ epytest tests -o addopts=
}