summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:50:59 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:50:59 +0100
commit008fe9423baeec93b263332b1d3df556edad2386 (patch)
treea11dc30a70d58be477ff9907ef2172a7f90b7428 /dev-python/lit
parentsys-devel/llvm: Delay llvm.org_set_globals after vars (diff)
downloadgentoo-008fe9423baeec93b263332b1d3df556edad2386.tar.gz
gentoo-008fe9423baeec93b263332b1d3df556edad2386.tar.bz2
gentoo-008fe9423baeec93b263332b1d3df556edad2386.zip
dev-python/lit: Delay llvm.org_set_globals after vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-11.0.0.9999.ebuild5
-rw-r--r--dev-python/lit/lit-12.0.0.9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/lit/lit-11.0.0.9999.ebuild b/dev-python/lit/lit-11.0.0.9999.ebuild
index eafbdc683987..8e876ebd8594 100644
--- a/dev-python/lit/lit-11.0.0.9999.ebuild
+++ b/dev-python/lit/lit-11.0.0.9999.ebuild
@@ -10,8 +10,6 @@ inherit distutils-r1 llvm.org
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( llvm/utils/lit )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -25,6 +23,9 @@ BDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
# TODO: move the manpage generation here (from sys-devel/llvm)
src_prepare() {
diff --git a/dev-python/lit/lit-12.0.0.9999.ebuild b/dev-python/lit/lit-12.0.0.9999.ebuild
index eafbdc683987..8e876ebd8594 100644
--- a/dev-python/lit/lit-12.0.0.9999.ebuild
+++ b/dev-python/lit/lit-12.0.0.9999.ebuild
@@ -10,8 +10,6 @@ inherit distutils-r1 llvm.org
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( llvm/utils/lit )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -25,6 +23,9 @@ BDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
# TODO: move the manpage generation here (from sys-devel/llvm)
src_prepare() {