summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-21 09:13:13 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-21 09:33:41 +0200
commitbff7d32a66fd5bb468a42c6649e9a8019fd324b8 (patch)
tree3964f2dec583035c3f1831fefc9da26880a6ab4f /dev-python/lit
parentsys-devel/llvm: Add 9.0 branch live ebuild (diff)
downloadgentoo-bff7d32a66fd5bb468a42c6649e9a8019fd324b8.tar.gz
gentoo-bff7d32a66fd5bb468a42c6649e9a8019fd324b8.tar.bz2
gentoo-bff7d32a66fd5bb468a42c6649e9a8019fd324b8.zip
dev-python/lit: Add 9.0 branch live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-9.0.9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/lit-9.0.9999.ebuild b/dev-python/lit/lit-9.0.9999.ebuild
new file mode 100644
index 000000000000..399ab4cc6df5
--- /dev/null
+++ b/dev-python/lit/lit-9.0.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1 git-r3 multiprocessing
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_90"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/lit
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
+}