summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-17 20:33:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-17 20:57:02 +0200
commit234a7e283e597d2a9b05ee362f9c5adb322bf3e6 (patch)
tree9fa7f91199fd9926fd9bc34e961990a3cae49884 /dev-python/markdown-exec/markdown-exec-1.7.0.ebuild
parentdev-python/trove-classifiers: Bump to 2023.10.17 (diff)
downloadgentoo-234a7e283e597d2a9b05ee362f9c5adb322bf3e6.tar.gz
gentoo-234a7e283e597d2a9b05ee362f9c5adb322bf3e6.tar.bz2
gentoo-234a7e283e597d2a9b05ee362f9c5adb322bf3e6.zip
dev-python/markdown-exec: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown-exec/markdown-exec-1.7.0.ebuild')
-rw-r--r--dev-python/markdown-exec/markdown-exec-1.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/markdown-exec/markdown-exec-1.7.0.ebuild b/dev-python/markdown-exec/markdown-exec-1.7.0.ebuild
new file mode 100644
index 000000000000..cc61bb807537
--- /dev/null
+++ b/dev-python/markdown-exec/markdown-exec-1.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Utilities to execute code blocks in Markdown files"
+HOMEPAGE="
+ https://pawamoy.github.io/markdown-exec/
+ https://pypi.org/project/markdown-exec/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="ansi"
+
+RDEPEND="
+ >=dev-python/pymdown-extensions-9[${PYTHON_USEDEP}]
+ ansi? (
+ dev-python/pygments-ansi-color[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest