summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/markups
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/markups')
-rw-r--r--dev-python/markups/Manifest3
-rw-r--r--dev-python/markups/markups-0.2.4-r1.ebuild35
-rw-r--r--dev-python/markups/markups-0.6.1.ebuild38
-rw-r--r--dev-python/markups/markups-0.6.3.ebuild38
-rw-r--r--dev-python/markups/metadata.xml11
5 files changed, 125 insertions, 0 deletions
diff --git a/dev-python/markups/Manifest b/dev-python/markups/Manifest
new file mode 100644
index 000000000000..ee8e05c11e90
--- /dev/null
+++ b/dev-python/markups/Manifest
@@ -0,0 +1,3 @@
+DIST Markups-0.2.4.tar.gz 8827 SHA256 0aab138698035e699fad1c88bebb3fa5e90a1876bc7d8fefb3491513fe13f16b SHA512 369eda02474f723d694bc0518324afde9f5baef02719448abb420a77d58cf1543939e6d38aa1db531d4214dc4cd4c47b29d79fa7a23b33b4ae74b45ad2ec52c7 WHIRLPOOL 1118723f5b9725b68d052e2496ccee414782bd6cceaedc49f9c2918c4055145fb95d49cf962c46eb669ab7a3a8659b86ed54fa5b99f6ac91266cebc4ecf01b10
+DIST Markups-0.6.1.tar.gz 19116 SHA256 1f3d6f7b85ac9ddcb936b8b2b6fa15a42ddc9dfc22a075d83d9160b5d59f6d84 SHA512 f1354af48aadb43459e8f0c2013d283c4f6170f608c4ca4a2dd21e77c6fc2383bd6a1631efc9a8878c4a0ba59249528222ba01d1a38ed3f02c6890d42c6afdb9 WHIRLPOOL 2db23d6cb9a282eb461a6ff49b21d1e1a57b6bc970739413efe4bbffdff6bc55d076db4546f0ff458c9cd8b66c389daa21e9cad7341d614109891c9a2b46acc2
+DIST Markups-0.6.3.tar.gz 19285 SHA256 e3ff5de2be018240c526e017972b37181cb3d5dfb7c96ad14eae6639140f58ef SHA512 61b3921595628f577d335c9eb7e405435c1547a6d5d06396e4181a0f3ac0bce8f5a72b5c51568ceeec96c86524ec4baa1cbcb807f545a630a87d807b9e12c97b WHIRLPOOL 9aad9486e57831fbca7124cb06dc84fd69df3036d7f08e8168b9969e83b58a32250cb82c90b70344f60d30c03fb3c7171f698fb8ba6ea23f5c296bb6d8b80ba2
diff --git a/dev-python/markups/markups-0.2.4-r1.ebuild b/dev-python/markups/markups-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..f2140c478e7d
--- /dev/null
+++ b/dev-python/markups/markups-0.2.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Markups"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="http://pypi.python.org/pypi/Markups"
+SRC_URI="mirror://pypi/M/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S="${WORKDIR}"/${MY_P}
+
+DEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ pushd tests > /dev/null
+ for test in test_*.py ; do
+ local testName="$(echo ${test} | sed 's/test_\(.*\).py/\1/g')"
+ einfo "Running test '${testName}' with '${EPYTHON}'."
+ ${EPYTHON} ${test} || die "Test '${testName}' with '${EPYTHON}' failed."
+ done
+ popd tests > /dev/null
+}
diff --git a/dev-python/markups/markups-0.6.1.ebuild b/dev-python/markups/markups-0.6.1.ebuild
new file mode 100644
index 000000000000..703b6cfcc322
--- /dev/null
+++ b/dev-python/markups/markups-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Markups"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="http://pypi.python.org/pypi/Markups"
+SRC_URI="mirror://pypi/M/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"/${MY_P}
+
+DEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ pushd tests > /dev/null
+ for test in test_*.py ; do
+ local testName="$(echo ${test} | sed 's/test_\(.*\).py/\1/g')"
+ if [[ ${testName} == "web" ]]; then
+ $(python_is_python3) || continue
+ fi
+ einfo "Running test '${testName}' with '${EPYTHON}'."
+ ${EPYTHON} ${test} || die "Test '${testName}' with '${EPYTHON}' failed."
+ done
+ popd tests > /dev/null
+}
diff --git a/dev-python/markups/markups-0.6.3.ebuild b/dev-python/markups/markups-0.6.3.ebuild
new file mode 100644
index 000000000000..703b6cfcc322
--- /dev/null
+++ b/dev-python/markups/markups-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Markups"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="http://pypi.python.org/pypi/Markups"
+SRC_URI="mirror://pypi/M/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"/${MY_P}
+
+DEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ pushd tests > /dev/null
+ for test in test_*.py ; do
+ local testName="$(echo ${test} | sed 's/test_\(.*\).py/\1/g')"
+ if [[ ${testName} == "web" ]]; then
+ $(python_is_python3) || continue
+ fi
+ einfo "Running test '${testName}' with '${EPYTHON}'."
+ ${EPYTHON} ${test} || die "Test '${testName}' with '${EPYTHON}' failed."
+ done
+ popd tests > /dev/null
+}
diff --git a/dev-python/markups/metadata.xml b/dev-python/markups/metadata.xml
new file mode 100644
index 000000000000..b871cab52806
--- /dev/null
+++ b/dev-python/markups/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Markups</remote-id>
+ </upstream>
+</pkgmetadata>