summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-16 06:53:37 +0100
committerSam James <sam@gentoo.org>2023-08-16 06:55:44 +0100
commit01500ab07fd2a2d423ce457691bf9c570ef465b9 (patch)
tree12682f302cf9f911768802409a874d164840c34f /dev-python/matplotlib/matplotlib-3.7.1.ebuild
parentsys-libs/libblockdev: depend on dev-python/pygobject (diff)
downloadgentoo-01500ab07fd2a2d423ce457691bf9c570ef465b9.tar.gz
gentoo-01500ab07fd2a2d423ce457691bf9c570ef465b9.tar.bz2
gentoo-01500ab07fd2a2d423ce457691bf9c570ef465b9.zip
dev-python/matplotlib: conditionalise gtk+, pygobject test deps
The test suite skips correctly if gtk+ is disabled and works fine if pygobject isn't installed as well. The only snag is that libblockdev installs a Python module (gi.*) where gi (pygobject) itself may not be installed, so that's fixed in 87fe7688480db245fa772b2f750259ea6213c266. Previously, that was confusing mpl's 'import gi' check. See also: https://github.com/gentoo/gentoo/pull/32331 Bug: https://bugs.gentoo.org/807637 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib/matplotlib-3.7.1.ebuild')
-rw-r--r--dev-python/matplotlib/matplotlib-3.7.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.7.1.ebuild b/dev-python/matplotlib/matplotlib-3.7.1.ebuild
index d0f4addd4224..1b925186597a 100644
--- a/dev-python/matplotlib/matplotlib-3.7.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.7.1.ebuild
@@ -111,9 +111,11 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
>=dev-python/tornado-6.0.4[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]
+ gtk3? (
+ >=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ )
)
"