summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-20 18:15:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-20 18:31:46 +0200
commit1a44307668d711c65d3d226145ef378185d02065 (patch)
tree3f5133fa350fdbbf9226b0112b8174df09d8230e /dev-python/matplotlib
parentdev-python/pygobject: Fix ImportWarnings with py3.10 (diff)
downloadgentoo-1a44307668d711c65d3d226145ef378185d02065.tar.gz
gentoo-1a44307668d711c65d3d226145ef378185d02065.tar.bz2
gentoo-1a44307668d711c65d3d226145ef378185d02065.zip
dev-python/matplotlib: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.4.2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.4.2.ebuild b/dev-python/matplotlib/matplotlib-3.4.2.ebuild
index 54f4fde613b6..2bc085e89cfb 100644
--- a/dev-python/matplotlib/matplotlib-3.4.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.4.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
@@ -50,7 +50,7 @@ RDEPEND="
dev-python/xlwt[${PYTHON_USEDEP}]
)
gtk3? (
- dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
)
latex? (
@@ -69,7 +69,9 @@ RDEPEND="
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
)
wxwidgets? (
- dev-python/wxpython:*[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ ' python3_{8,9})
)
"
@@ -93,7 +95,7 @@ BDEPEND="
test? (
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
)