summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTadej Borovšak <tadeboro@gmail.com>2017-07-15 22:56:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-15 23:42:06 +0200
commit2680e441fa13ed000b774a813512a653e1c0c8f6 (patch)
tree986d824cf0b2804170c86160c5c334fc8a5b2ba9 /dev-python/matplotlib
parentdev-python/urwid: clean up old. (diff)
downloadgentoo-2680e441fa13ed000b774a813512a653e1c0c8f6.tar.gz
gentoo-2680e441fa13ed000b774a813512a653e1c0c8f6.tar.bz2
gentoo-2680e441fa13ed000b774a813512a653e1c0c8f6.zip
dev-python/matplotlib: fix wrap_setup function.
Wrapper for python_compile() function only prepared environment for the compile call, but never executed it. Gentoo-Bug: https://bugs.gentoo.org/624554 Closes: https://github.com/gentoo/gentoo/pull/5112
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-2.0.2.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-python/matplotlib/matplotlib-2.0.2.ebuild b/dev-python/matplotlib/matplotlib-2.0.2.ebuild
index cf16b2b42e5b..e8214110ebfe 100644
--- a/dev-python/matplotlib/matplotlib-2.0.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-2.0.2.ebuild
@@ -209,6 +209,7 @@ python_configure() {
wrap_setup() {
local -x MPLSETUPCFG=${BUILD_DIR}/setup.cfg
unset DISPLAY
+ "$@"
}
python_compile() {