summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-07-09 21:01:12 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-07-09 21:06:41 +0900
commit7385d90ccac06d78c8bf90029c399b01d1883e39 (patch)
treeb35419516e02a2a3b7cc9147cf353b1ae592bcd8 /dev-python/matplotlib
parentsys-auth/polkit-qt: add snapshot (diff)
downloadgentoo-7385d90ccac06d78c8bf90029c399b01d1883e39.tar.gz
gentoo-7385d90ccac06d78c8bf90029c399b01d1883e39.tar.bz2
gentoo-7385d90ccac06d78c8bf90029c399b01d1883e39.zip
dev-python/matplotlib: remove bundled qhull
remove directory quotes from setup.cfg to enable it find qhull in Gentoo. update wrap_setup for the fact that we are already doing out-of-source builds. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-2.0.2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-python/matplotlib/matplotlib-2.0.2.ebuild b/dev-python/matplotlib/matplotlib-2.0.2.ebuild
index ca8d819c6eec..8a1a98034922 100644
--- a/dev-python/matplotlib/matplotlib-2.0.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-2.0.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
PYTHON_REQ_USE='tk?,threads(+)'
-inherit distutils-r1 flag-o-matic virtualx toolchain-funcs
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
DESCRIPTION="Pure python plotting library with matlab like syntax"
HOMEPAGE="http://matplotlib.org/"
@@ -45,7 +45,7 @@ COMMON_DEPEND="
media-fonts/stix-fonts
media-libs/freetype:2
media-libs/libpng:0
- media-libs/qhull
+ >=media-libs/qhull-2013
cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
gtk2? (
dev-libs/glib:2=
@@ -144,14 +144,14 @@ python_prepare_all() {
-i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
|| die "sed pyparsing failed"
- sed \
- -e "s:/usr/:${EPREFIX}/usr/:g" \
- -i setupext.py || die
+ hprefixify setupext.py
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
+ rm -r extern/qhull || die
+
distutils-r1_python_prepare_all
}
@@ -169,7 +169,7 @@ python_configure() {
# common switches.
cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
[directories]
- basedirlist = "${EPREFIX}/usr"
+ basedirlist = ${EPREFIX}/usr
[provide_packages]
pytz = False
dateutil = False
@@ -209,13 +209,10 @@ python_configure() {
wrap_setup() {
local -x MPLSETUPCFG=${BUILD_DIR}/setup.cfg
unset DISPLAY
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
}
python_compile() {
- wrap_setup distutils-r1_python_compile
+ wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
}
python_compile_all() {