summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-11 22:01:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-12-12 00:24:44 +0100
commitab013e15619d9fbf7494770961f971265c54d9b2 (patch)
tree385f12a7a4e0b6d5c71aa8ef719f5faa9123faa9 /dev-python/minikanren
parentdev-python/etuples: new dep of dev-python/minikanren, add 0.3.3 (diff)
downloadgentoo-ab013e15619d9fbf7494770961f971265c54d9b2.tar.gz
gentoo-ab013e15619d9fbf7494770961f971265c54d9b2.tar.bz2
gentoo-ab013e15619d9fbf7494770961f971265c54d9b2.zip
dev-python/minikanren: new dep of dev-python/aesara, add 1.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/minikanren')
-rw-r--r--dev-python/minikanren/Manifest1
-rw-r--r--dev-python/minikanren/metadata.xml13
-rw-r--r--dev-python/minikanren/minikanren-1.0.2.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/minikanren/Manifest b/dev-python/minikanren/Manifest
new file mode 100644
index 000000000000..187db17d26f5
--- /dev/null
+++ b/dev-python/minikanren/Manifest
@@ -0,0 +1 @@
+DIST minikanren-1.0.2.gh.tar.gz 70501 BLAKE2B 59efa4d62a2f896d310ebe522a6c77aaddc54be4d2a8fcf3aa29f3f5f4dcb3ac57823514661d5900e38f0ebd0e0247e7d99bbab53afaaf243e39084f357a0361 SHA512 278b6f3d0666c1ac1baad29ee9c767039922a7b7ffdbdd543c8ccfc65a7d54c3353327abbd7c5c41fa3194ddc00044cff1e975e51f8f5ea5a64c8c2bcfac17e2
diff --git a/dev-python/minikanren/metadata.xml b/dev-python/minikanren/metadata.xml
new file mode 100644
index 000000000000..c1cc25a77788
--- /dev/null
+++ b/dev-python/minikanren/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">miniKanren</remote-id>
+ <remote-id type="github">pythological/kanren</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/minikanren/minikanren-1.0.2.ebuild b/dev-python/minikanren/minikanren-1.0.2.ebuild
new file mode 100644
index 000000000000..164c0c9b8412
--- /dev/null
+++ b/dev-python/minikanren/minikanren-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Relational programming in Python"
+HOMEPAGE="
+ https://pypi.org/project/miniKanren/
+ https://github.com/pythological/kanren/
+"
+SRC_URI="
+ https://github.com/pythological/kanren/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/kanren-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest