summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-22 13:43:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-22 13:44:11 +0300
commita6ad7ac337c36f02b6f5010a492a61c7a5bfcd8c (patch)
tree4d9f519fd25767319354ce28fbaeb47670c46a6b /dev-python/mkdocs-material
parentmedia-libs/tiff: Remove old (diff)
downloadgentoo-a6ad7ac337c36f02b6f5010a492a61c7a5bfcd8c.tar.gz
gentoo-a6ad7ac337c36f02b6f5010a492a61c7a5bfcd8c.tar.bz2
gentoo-a6ad7ac337c36f02b6f5010a492a61c7a5bfcd8c.zip
dev-python/mkdocs-material: fix build
Closes: https://bugs.gentoo.org/877897 Follows: 9a4c11ae1d1c1b00b07dcf7668dcaa91946e969e Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-material')
-rw-r--r--dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch23
-rw-r--r--dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild2
2 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch b/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch
index c0f07eac494f..ac696c40710f 100644
--- a/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch
+++ b/dev-python/mkdocs-material/files/mkdocs-material-8.5.7-simplify-build.patch
@@ -1,27 +1,28 @@
-From: Arthur Zamarin <arthurzam@gentoo.org>
-
-Simplify dependencies used for metadata generation.
-
+diff --git a/pyproject.toml b/pyproject.toml
+index c5bd914c0..3757e983b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -19,7 +19,7 @@
# IN THE SOFTWARE.
-
+
[build-system]
-requires = ["hatchling", "hatch-requirements-txt", "hatch-nodejs-version>=0.3.0"]
+requires = ["hatchling"]
build-backend = "hatchling.build"
-
+
[project]
-@@ -55,10 +55,7 @@ tags = "material.plugins.tags.plugin:TagsPlugin"
+@@ -55,13 +55,7 @@ tags = "material.plugins.tags.plugin:TagsPlugin"
material = "material"
-
+
[tool.hatch.version]
-source = "nodejs"
-
-[tool.hatch.metadata.hooks.nodejs]
-fields = ["license", "description", "authors", "keywords", "urls"]
+-
+-[tool.hatch.metadata.hooks.requirements_txt]
+-filename = "requirements.txt"
+path = "gentoo_version.py"
-
- [tool.hatch.metadata.hooks.requirements_txt]
- filename = "requirements.txt"
+
+ [tool.hatch.build.targets.wheel]
+ include = ["/material"]
diff --git a/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild b/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild
index 4f1e1fca0123..2071af80ea70 100644
--- a/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild
+++ b/dev-python/mkdocs-material/mkdocs-material-8.5.7.ebuild
@@ -45,7 +45,7 @@ PATCHES=(
"${FILESDIR}/${PN}-8.5.7-simplify-build.patch"
)
-_src_prepare() {
+src_prepare() {
echo "__version__ = '${PV}'"> gentoo_version.py || die
distutils-r1_src_prepare
}