summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-07-24 14:00:29 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-07-24 14:15:23 -0700
commit4b58be87e36d805c68c2f35371e3e85830720c8d (patch)
treedf2ff458c4e90ee2476203bb256a45efeff20832 /dev-python/moto
parentdev-python/ndg-httpsclient: x86 stable (bug #720552) (diff)
downloadgentoo-4b58be87e36d805c68c2f35371e3e85830720c8d.tar.gz
gentoo-4b58be87e36d805c68c2f35371e3e85830720c8d.tar.bz2
gentoo-4b58be87e36d805c68c2f35371e3e85830720c8d.zip
dev-python/moto: Fix idna dep requirement bug 733728
installed requires.txt was limiting the idna dep outside of the ebuild DEPEND. Remove the upper limit and tested with idna-2.10 OK. Fixes a test failure bug in dev-util/buildbot. Closes: https://bugs.gentoo.org/733728 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/moto-1.3.14-r3.ebuild (renamed from dev-python/moto/moto-1.3.14-r2.ebuild)3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/moto/moto-1.3.14-r2.ebuild b/dev-python/moto/moto-1.3.14-r3.ebuild
index 89915445bd5a..f28e5d50579d 100644
--- a/dev-python/moto/moto-1.3.14-r2.ebuild
+++ b/dev-python/moto/moto-1.3.14-r3.ebuild
@@ -69,6 +69,9 @@ python_prepare_all() {
-e '/cfn-lint/ d' \
-i setup.py moto.egg-info/requires.txt || die
+ sed -e 's|idna<2.9,>=2.5|idna>=2.5|' \
+ -i setup.py moto.egg-info/requires.txt || die
+
# Disable tests that fail with network-sandbox.
sed -e 's|^\(def \)\(test_context_manager()\)|\1_\2|' \
-e 's|^\(def \)\(test_decorator_start_and_stop()\)|\1_\2|' \