summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-26 19:14:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 19:14:04 +0200
commitf6b765a289c14adab0aea95a2054982e26d34cb5 (patch)
tree35935b16e62550b843c6a745b426d54ea488358c /dev-python/nbxmpp
parentdev-python/ujson: Enable py3.12 (diff)
downloadgentoo-f6b765a289c14adab0aea95a2054982e26d34cb5.tar.gz
gentoo-f6b765a289c14adab0aea95a2054982e26d34cb5.tar.bz2
gentoo-f6b765a289c14adab0aea95a2054982e26d34cb5.zip
dev-python/nbxmpp: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbxmpp')
-rw-r--r--dev-python/nbxmpp/Manifest1
-rw-r--r--dev-python/nbxmpp/nbxmpp-4.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nbxmpp/Manifest b/dev-python/nbxmpp/Manifest
index 0147d4cb5a0d..cad19b83deea 100644
--- a/dev-python/nbxmpp/Manifest
+++ b/dev-python/nbxmpp/Manifest
@@ -1,2 +1,3 @@
DIST python-nbxmpp-3.2.5.tar.bz2 132029 BLAKE2B 846f3b47c3a9a95cf1fa1b557a007fd4901fb4acaa3160ea4b9b1cdff1e9d2c3e64bc5251b739d816f3f1c449c350d1ac44c14cbef87d14fe5a6450418451007 SHA512 577f8c7b0f5a7c69b4d980bff93f0a208ab0a660d731eb95ec63b76583194b94bd9d9f6b10fcac3951a6e6afb5d0c4da2140cbc17ef653f19ec6957b5d2e5f04
DIST python-nbxmpp-4.2.2.tar.bz2 133951 BLAKE2B 4ef9d7a6b2f1a548eac3d97eee322badbce5c69114441145ee525df45c5291771de3171e6591c0962dfe077fd9bc9fc83b8caeaefaeb13e0eb65b4ebcb5d37c7 SHA512 6edf469354ad1bb1eeb2545f67b4e7cf2362becfb2cc8c2caa6f050d56c0c15ac2fd29d52095d673199da7170ccfddbf7e8d8f98c47882ab75d14d19f71a81d9
+DIST python-nbxmpp-4.3.0.tar.bz2 135597 BLAKE2B e0d193bc8c99aa473c013607d341b4b0adc8a3639f8f51c2d00ac8f7d5fbd779540f791d44e685f54e46b3df140c18611fe252bdaad7cb5e650318ac8cdfd70f SHA512 da1fc22d51d7ffbe5a1df5fffd33c16c131348713f6e56b1d654d3f3c0e30e9dae9745ff6f20148e746205b74e8180dbf322e5f603475d85779ab2e075d22835
diff --git a/dev-python/nbxmpp/nbxmpp-4.3.0.ebuild b/dev-python/nbxmpp/nbxmpp-4.3.0.ebuild
new file mode 100644
index 000000000000..570d6eeeb400
--- /dev/null
+++ b/dev-python/nbxmpp/nbxmpp-4.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.42[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest