summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-02 04:31:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-02 04:35:00 +0200
commit83c78b422c5f3135553a2ee73a911136104f979f (patch)
tree07aedcfc399b80d3d8b649b2dcdbc0b9cc8df10d /dev-python/nose2
parentdev-python/pycountry: Bump to 24.6.1 (diff)
downloadgentoo-83c78b422c5f3135553a2ee73a911136104f979f.tar.gz
gentoo-83c78b422c5f3135553a2ee73a911136104f979f.tar.bz2
gentoo-83c78b422c5f3135553a2ee73a911136104f979f.zip
dev-python/nose2: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nose2')
-rw-r--r--dev-python/nose2/Manifest1
-rw-r--r--dev-python/nose2/nose2-0.15.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
index cafff1507ec3..0c87660f126f 100644
--- a/dev-python/nose2/Manifest
+++ b/dev-python/nose2/Manifest
@@ -1,2 +1,3 @@
DIST nose2-0.14.2.tar.gz 167874 BLAKE2B b2d1d1d026de10e9d73a312205b0562c377775016b8adea0b64213cb32930e9a58823021fa970f23e8acd79d2ea2a3df1f294732fcb2f96c454a2345f65091db SHA512 728d6c3f1c037630b6b3a4fc3012a488d91dfdcef5fe1d1f6473b317f71ac6ba16a33d33721de7422caec019eac00137e95190eb2c98edd67c4c5f7f8ee09440
DIST nose2-0.15.0.tar.gz 168825 BLAKE2B fc61b1be549cc725a05825cc801b23fa3055b13f745f63c5a1929b87724691001cf743248cb9606b6ae11b32090b99de0e583dac175141a6a6c9e5efb5a16099 SHA512 e0c1287aec4092fba55814bca8f5ac867d2ac0f9c9da15d6eb955007050b7e4beb2f211d049acc4dce9fa9990bc42468d01f2945cc358127295b60f9a5f998a6
+DIST nose2-0.15.1.tar.gz 169809 BLAKE2B a3ae7c3036fc50851f8cc47df3c5677a1d2333a664802aa03af16c2f600366b5b51b2f6ad6c0953977edf3d63b7e5ac593f2f1ce26382256a6b81680cba7e39b SHA512 118b1144369b72c6af4153b866d19253b31cb019407f8c4b9f80461b105be8851be7b6524a822da8ddca039f733510b5e5d7871608195d0fb8d7be9de1938762
diff --git a/dev-python/nose2/nose2-0.15.1.ebuild b/dev-python/nose2/nose2-0.15.1.ebuild
new file mode 100644
index 000000000000..5aa2066d832e
--- /dev/null
+++ b/dev-python/nose2/nose2-0.15.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}