summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:24:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:25:32 +0200
commita503f4337f478f6857fc4cf00c0112d8409e6eaf (patch)
treed3bc841ac3efbf3de58d59059d4ea93123dd2013 /dev-python/numexpr
parentapp-admin/mcelog: add 182 (diff)
downloadgentoo-a503f4337f478f6857fc4cf00c0112d8409e6eaf.tar.gz
gentoo-a503f4337f478f6857fc4cf00c0112d8409e6eaf.tar.bz2
gentoo-a503f4337f478f6857fc4cf00c0112d8409e6eaf.zip
dev-python/numexpr: pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/numexpr-2.8.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/numexpr/numexpr-2.8.1-r1.ebuild b/dev-python/numexpr/numexpr-2.8.1-r1.ebuild
new file mode 100644
index 000000000000..494235d35671
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.8.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd "${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages" >/dev/null || die
+ "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
+ import sys,numexpr
+ sys.exit(0 if numexpr.test().wasSuccessful() else 1)
+ EOF
+ pushd >/dev/null || die
+}