summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-15 05:43:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-15 05:47:52 +0200
commit70368d65b083389e66cee361030824c8bee239a7 (patch)
tree6353e91e7d73e0cf18a3c1fe782f41f1fcd81056 /dev-python/openapi-core
parentdev-python/webob: Bump to 1.8.8 (diff)
downloadgentoo-70368d65b083389e66cee361030824c8bee239a7.tar.gz
gentoo-70368d65b083389e66cee361030824c8bee239a7.tar.bz2
gentoo-70368d65b083389e66cee361030824c8bee239a7.zip
dev-python/openapi-core: Bump to 0.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.19.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index a6f20fc95c06..740322ea03e6 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1 +1,2 @@
DIST openapi_core-0.19.2.tar.gz 108121 BLAKE2B 0873ba33c0270babb3c3e626e942fd22fc066f8ef408c6f1cadab8140fdb6284d21a1cb5ed767c7f0f370112a1bb263ac50b340cccfe1cba6da1a0f15a73bbde SHA512 cab2343c61bbb8de048b5e3a53c2d753468f6707f3b4b40ddfee7c3ea6eb0f3beff0aebcad632200a5a4b08e93c620aceda659297756d4f587d11039ede0eefa
+DIST openapi_core-0.19.3.tar.gz 109026 BLAKE2B e7725fd14069599a3f4f0d976452fca9b12acd39c2a0fb7b448ee862d9fa973c520b1e428e017a7f246c7110b56d58c299aa35c8f387cf43af6e9a53da2f1418 SHA512 87db8e0a1c5998fb4dbe3bfaf5c33b526e291ad96bb4a679fcb68ce21b003a66b40db14c4784f80104d4462c1e958a1b7776fb3d952e68eb4a7308999896c08b
diff --git a/dev-python/openapi-core/openapi-core-0.19.3.ebuild b/dev-python/openapi-core/openapi-core-0.19.3.ebuild
new file mode 100644
index 000000000000..c847f13acce7
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.19.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.6.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-path-0.4[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-path-0.3.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.8[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.7.1[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/aiohttp-3.8.4[${PYTHON_USEDEP}]
+ >=dev-python/aioitertools-0.11.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-aiohttp-1.0.4[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.26.1[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # missing dependendencies
+ tests/integration/contrib/falcon
+ tests/integration/contrib/fastapi
+
+ # TODO: these tests fail to collect
+ tests/integration/validation/test_security_override.py
+ tests/integration/validation/test_read_only_write_only.py
+
+ # unhappy about modern django
+ tests/integration/contrib/django/test_django_project.py
+ tests/unit/contrib/django/test_django.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}