summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-21 21:01:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-21 21:12:56 +0200
commit5904778191229bb009b799a031c166de730b5c6b (patch)
tree3e31844ef865d1c4f4edc14541fe6d1c052f5df9 /dev-python/oslo-i18n
parentdev-python/spyder-kernels: Bump to 3.0.0_beta9 (diff)
downloadgentoo-5904778191229bb009b799a031c166de730b5c6b.tar.gz
gentoo-5904778191229bb009b799a031c166de730b5c6b.tar.bz2
gentoo-5904778191229bb009b799a031c166de730b5c6b.zip
dev-python/oslo-i18n: Bump to 6.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest1
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-6.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index 2d67e2ff6f68..cd86ab5a72d2 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1 +1,2 @@
DIST oslo.i18n-6.3.0.tar.gz 48207 BLAKE2B 20a882516dd45da8dda34127ba422a619decd982f01adeee5909b8646d49c8609ecb6adad4fc48ab32e820c4dcf4a42d4baf7e776983daf4586ae944b738bb6e SHA512 483ff39425b3fc5c6c54a3502a78a53406ccb3cdb7aff0836b9c2a49b8146fd931e2b4f3133d708d33d16bd99155f8cbcf8505491d74de5016da5e647a069a15
+DIST oslo.i18n-6.4.0.tar.gz 48196 BLAKE2B 14a366d1042f288133a3a15ca14264446a6775318ab7347331b91fe4f36149c1592d920e6ce309a0db2ba8bb76209f2b6c917b4de8733427f3f9afd46bd7a295 SHA512 f68f5fb731175086f99f8a74e734f81fab4a19de3ce087279a55b7ec6df9a30a2eb70325faf2f3228fe11bb808d11b5f87eef93cc55e5b33ce4ed4e881d3915b
diff --git a/dev-python/oslo-i18n/oslo-i18n-6.4.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-6.4.0.ebuild
new file mode 100644
index 000000000000..a1e5278ba439
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-6.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.i18n/
+ https://github.com/openstack/oslo.i18n/
+ https://pypi.org/project/oslo.i18n/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest