summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-06 22:07:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-06 22:13:36 +0200
commit5e0813a0519a74e63728a8a4854e3e12536735e8 (patch)
tree4b16196ccb50f4e556756afe82255d0dbe160708 /dev-python/oslo-i18n
parentdev-python/oslotest: Bump to 4.5.0 (diff)
downloadgentoo-5e0813a0519a74e63728a8a4854e3e12536735e8.tar.gz
gentoo-5e0813a0519a74e63728a8a4854e3e12536735e8.tar.bz2
gentoo-5e0813a0519a74e63728a8a4854e3e12536735e8.zip
dev-python/oslo-i18n: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest1
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index fe6bee888c34..983fbfd4be68 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1 +1,2 @@
DIST oslo.i18n-5.0.1.tar.gz 44636 BLAKE2B 69df723bff7a279ace2a8bb2ea795e6beaa626ffc4bb364c513d16d2ce3cb07f6e9957a98d1b633f95154672d118de6fbb71ef5c1a3a53520f4d1f4b8f72748f SHA512 d55238616dc90f85ff458fc6680b3a3b2493d2a640bf5849c19cd7271e7127b535a301ed3085b5e0131b46a635b5a09423f6cba60f9f1b9b0352a0e7115a8057
+DIST oslo.i18n-5.1.0.tar.gz 47423 BLAKE2B 621ec835fc975978fe3da392edda66471cd85fcfbe5af8c7a1704d7422d8f52f3b61c97ac8cfbd2aca94f65c8428cc5f97b095bc116ece605a4dc325a4a0171e SHA512 b2243f22de3ef3e33609c5aff573c4448a42c74d75022e023bea97c5338608e3fcd9da92aa2d262051e6b2ccbd5a88cfb2c91da79b7e3f81420dc24117da9b1d
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.1.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.1.0.ebuild
new file mode 100644
index 000000000000..9796fa081884
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-5.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+"
+BDEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest