summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-29 05:55:51 +0100
committerSam James <sam@gentoo.org>2023-08-29 05:57:35 +0100
commita1141b6f49501f8bc5ad7cd58d4c15852beb52b6 (patch)
tree8c7b8755f7d912f8b0042d0ef9ac74c62b055a3a /dev-python/pandas
parentdev-python/pymdown-extensions: Bump to 10.2 (diff)
downloadgentoo-a1141b6f49501f8bc5ad7cd58d4c15852beb52b6.tar.gz
gentoo-a1141b6f49501f8bc5ad7cd58d4c15852beb52b6.tar.bz2
gentoo-a1141b6f49501f8bc5ad7cd58d4c15852beb52b6.zip
dev-python/pandas: skip known-broken tests
Closes: https://bugs.gentoo.org/911660 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/pandas-2.0.3-r1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/pandas/pandas-2.0.3-r1.ebuild b/dev-python/pandas/pandas-2.0.3-r1.ebuild
index 961cd1e3b860..f2867585543e 100644
--- a/dev-python/pandas/pandas-2.0.3-r1.ebuild
+++ b/dev-python/pandas/pandas-2.0.3-r1.ebuild
@@ -211,6 +211,15 @@ python_test() {
'pandas/tests/tseries/offsets/test_common.py::test_apply_out_of_range[tzlocal()-LastWeekOfMonth]'
'pandas/tests/tseries/offsets/test_common.py::test_apply_out_of_range[tzlocal()-WeekOfMonth]'
'pandas/tests/tseries/offsets/test_common.py::test_apply_out_of_range[tzlocal()-Week]'
+
+ # alignment issues: bug #911660 (fixed upstream but not yet in a release)
+ # https://github.com/pandas-dev/pandas/issues/54391
+ pandas/tests/io/sas/test_byteswap.py::test_float_byteswap
+
+ # hdf / pytables have alignment problems: bug #911660
+ # https://github.com/pandas-dev/pandas/issues/54396
+ pandas/tests/io/pytables/test_append.py::test_append_frame_column_oriented
+ pandas/tests/io/pytables/test_store.py::test_select_filter_corner
)
local -x LC_ALL=C.UTF-8