summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 18:12:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 18:30:43 +0100
commit19235b01e5c62d44ae0245bfd1c8d267fd2b294b (patch)
treecb350d82852d792d6f36edd38cf97d36f3437d0d /dev-python/paste/paste-3.5.0.ebuild
parentdev-python/jaraco-text: Remove namespace dep (diff)
downloadgentoo-19235b01e5c62d44ae0245bfd1c8d267fd2b294b.tar.gz
gentoo-19235b01e5c62d44ae0245bfd1c8d267fd2b294b.tar.bz2
gentoo-19235b01e5c62d44ae0245bfd1c8d267fd2b294b.zip
dev-python/paste: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste/paste-3.5.0.ebuild')
-rw-r--r--dev-python/paste/paste-3.5.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/paste/paste-3.5.0.ebuild b/dev-python/paste/paste-3.5.0.ebuild
deleted file mode 100644
index ceb33d7884b9..000000000000
--- a/dev-python/paste/paste-3.5.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
-
-inherit distutils-r1
-
-MY_P="Paste-${PV}"
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="https://pypi.org/project/Paste/"
-SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
-
-RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs
-
-python_prepare_all() {
- # TODO: 'Address already in use'
- sed -e 's:test_address_family_v4:_&:' \
- -i tests/test_httpserver.py || die
-
- # Remove a test that runs against the paste website.
- rm -f tests/test_proxy.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}