summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-26 06:28:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-26 06:42:12 +0200
commit76395a9af7c3ab61aa97faeb15902540ca00ae03 (patch)
tree76ebfc9c5231f13f1b0c8f9debe3f49961a38b54 /dev-python/pdm
parentdev-python/hcloud: Bump to 1.29.0 (diff)
downloadgentoo-76395a9af7c3ab61aa97faeb15902540ca00ae03.tar.gz
gentoo-76395a9af7c3ab61aa97faeb15902540ca00ae03.tar.bz2
gentoo-76395a9af7c3ab61aa97faeb15902540ca00ae03.zip
dev-python/pdm: Bump to 2.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest1
-rw-r--r--dev-python/pdm/pdm-2.9.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 518feb578f26..a2c03ef0c45a 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,3 +1,4 @@
DIST pdm-2.8.2.tar.gz 3014401 BLAKE2B a541339582944988b7a30d2991066287e0293845d4f15c7f6cb2fef7a8709dba537f190e5493bd3b06e7ef86fca601a9d1aab7af6ca6ae55269b374a7464ca17 SHA512 396e27902f74773070cf49c3857d93702e6678a46221b54dc03e84e2b8ccf211cbba9d24eba6bfc47ff36cbd4eb504ada5bf82071c884347026ba85c123058e9
DIST pdm-2.9.1.tar.gz 3017895 BLAKE2B 944a1cd9571f7ad2ec6b4212b29db7b6c7c5e8b12591c73dae19f099f9d511f0db3f0698d48e2e42fc81f30c876caa7c9e43467d23eee26876595e6fd6ff197e SHA512 979bf9d078747c7b8dd56555d499053b978ddf289af4bf889b2f2805255049c24bf48607b3704509d914eec59904cbdb9983af396c68ff7211cc216fd4b40118
DIST pdm-2.9.2.tar.gz 3018730 BLAKE2B 83eeab7b70efe61a515ed262e8bd1de911f111aaa22704fcce2e46824a236be663ba831cce8bb440e612e711b8cf0627b1a416e966b06b51dc6e25feb2e856b0 SHA512 1d3193dc31065a05989e9dc36518fac0d45f86945d68ff2b5e03473b97c70b0f9586849a1e2208e740921927857733c76c44b512213cb17fc6608f9d0d7bcbd9
+DIST pdm-2.9.3.tar.gz 2578245 BLAKE2B f3916294d83e4731514f7009fd9e71fbd06614f46f1eeed9ad1d591e34c09877815d75b09dbb58f5765011a2e75e4182571a446c3cb8061d2408cecd272f6c75 SHA512 110e6488f8b161f7d77b9f0b1f34964f1c93ae7e8e9b2109057cfe1f507c914c9c72b3d787c768c9d371a80d8d79bbf6cad006eca2fe88e33b22f4415f2d276e
diff --git a/dev-python/pdm/pdm-2.9.3.ebuild b/dev-python/pdm/pdm-2.9.3.ebuild
new file mode 100644
index 000000000000..a174c2dc09c3
--- /dev/null
+++ b/dev-python/pdm/pdm-2.9.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pdm.fming.dev/latest/
+ https://github.com/pdm-project/pdm/
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/truststore[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.10.0[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' pypy3 python3_10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ epytest -m "not network and not integration and not path"
+}