summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-08-16 12:47:47 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-08-16 13:02:50 +0200
commit91fa2dae233587597dced8ad951faa559b8fdc4d (patch)
tree692fcd1035e927c1a03f71c37a5ec0948f54769d /dev-python/pdoc3/pdoc3-0.10.0.ebuild
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.141 (diff)
downloadgentoo-91fa2dae233587597dced8ad951faa559b8fdc4d.tar.gz
gentoo-91fa2dae233587597dced8ad951faa559b8fdc4d.tar.bz2
gentoo-91fa2dae233587597dced8ad951faa559b8fdc4d.zip
dev-python/pdoc3: add 0.10.0
Compared to the previous version ebuild (0.9.2) in the 0.10.0 ebuild the unnecessary dev-python/wheel DEPEND was removed, the tests are now enabled and PYTHON_COMPAT minimum is now 3.8 (which allowed DISTUTILS_USE_SETUPTOOLS=rdepend to be dropped). Thanks to mgorny for spotting the superfluous wheel dependency. Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-python/pdoc3/pdoc3-0.10.0.ebuild')
-rw-r--r--dev-python/pdoc3/pdoc3-0.10.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pdoc3/pdoc3-0.10.0.ebuild b/dev-python/pdoc3/pdoc3-0.10.0.ebuild
new file mode 100644
index 000000000000..7769b43281fc
--- /dev/null
+++ b/dev-python/pdoc3/pdoc3-0.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Auto-generate API documentation for Python projects"
+HOMEPAGE="https://pdoc3.github.io/pdoc/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i \
+ -e "/setuptools_git/d" \
+ -e "/setuptools_scm/d" \
+ setup.py || die
+}
+
+distutils_enable_tests unittest