summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-29 12:23:41 +0000
committerSam James <sam@gentoo.org>2024-12-29 12:23:41 +0000
commit82b2f03f2c9f3a1fdba926bcaad205c295bef29d (patch)
treeaf6d31d54239f81c5da79ffa6fc07194e62f7ee5 /dev-python/pillow
parentprofiles/base: update default ADA_TARGET to gcc_13 (diff)
downloadgentoo-82b2f03f2c9f3a1fdba926bcaad205c295bef29d.tar.gz
gentoo-82b2f03f2c9f3a1fdba926bcaad205c295bef29d.tar.bz2
gentoo-82b2f03f2c9f3a1fdba926bcaad205c295bef29d.zip
dev-python/pillow: backport fix for automagic deps
Straight to stable given it's pretty nasty and a trivial fix. Closes: https://bugs.gentoo.org/947136 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/files/pillow-11.0.0-automagic-disable.patch26
-rw-r--r--dev-python/pillow/pillow-11.0.0-r2.ebuild151
2 files changed, 177 insertions, 0 deletions
diff --git a/dev-python/pillow/files/pillow-11.0.0-automagic-disable.patch b/dev-python/pillow/files/pillow-11.0.0-automagic-disable.patch
new file mode 100644
index 000000000000..81bd47dc4a8b
--- /dev/null
+++ b/dev-python/pillow/files/pillow-11.0.0-automagic-disable.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/947136
+https://github.com/python-pillow/Pillow/issues/8468
+https://github.com/python-pillow/Pillow/pull/8469
+
+From 7c194b54ef3e7a04c5b669353622687075b5ebb4 Mon Sep 17 00:00:00 2001
+From: Andrew Murray <radarhere@users.noreply.github.com>
+Date: Wed, 16 Oct 2024 21:37:14 +1100
+Subject: [PATCH] Fixed disabling a feature
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 60707083f6e..def3417845d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -389,7 +389,7 @@ def finalize_options(self) -> None:
+ pass
+ for x in self.feature:
+ if getattr(self, f"disable_{x}"):
+- setattr(self.feature, x, False)
++ self.feature.set(x, False)
+ self.feature.required.discard(x)
+ _dbg("Disabling %s", x)
+ if getattr(self, f"enable_{x}"):
diff --git a/dev-python/pillow/pillow-11.0.0-r2.ebuild b/dev-python/pillow/pillow-11.0.0-r2.ebuild
new file mode 100644
index 000000000000..95d2098b3325
--- /dev/null
+++ b/dev-python/pillow/pillow-11.0.0-r2.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# setuptools wrapper
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="
+ https://python-pillow.org/
+ https://github.com/python-pillow/Pillow/
+ https://pypi.org/project/pillow/
+"
+SRC_URI="
+ https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="examples imagequant +jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg jpeg2k lcms tiff truetype )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:= )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[png]
+ )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/python-pillow/pillow/pull/7634
+ "${FILESDIR}/${PN}-10.2.0-cross.patch"
+ # https://github.com/python-pillow/Pillow/issues/8522
+ "${FILESDIR}/${P}-wrong-arg.patch"
+ # https://github.com/python-pillow/Pillow/pull/8469
+ "${FILESDIR}/${P}-automagic-disable.patch"
+)
+
+usepil() {
+ usex "${1}" enable disable
+}
+
+python_configure_all() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ debug = True
+ disable_platform_guessing = True
+ $(usepil truetype)_freetype = True
+ $(usepil jpeg)_jpeg = True
+ $(usepil jpeg2k)_jpeg2000 = True
+ $(usepil lcms)_lcms = True
+ $(usepil tiff)_tiff = True
+ $(usepil imagequant)_imagequant = True
+ $(usepil webp)_webp = True
+ $(usepil xcb)_xcb = True
+ $(usepil zlib)_zlib = True
+ EOF
+ if use truetype; then
+ # these dependencies are implicitly disabled by USE=-truetype
+ # and we can't pass both disable_* and vendor_*
+ # https://bugs.gentoo.org/935124
+ cat >> setup.cfg <<-EOF || die
+ vendor_raqm = False
+ vendor_fribidi = False
+ EOF
+ fi
+
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO (is clipboard unreliable in Xvfb?)
+ Tests/test_imagegrab.py::TestImageGrab::test_grabclipboard
+ # requires xz-utils[extra-filters]?
+ Tests/test_file_libtiff.py::TestFileLibTiff::test_lzma
+ )
+
+ case ${ARCH} in
+ ppc)
+ EPYTEST_DESELECT+=(
+ # https://github.com/python-pillow/Pillow/issues/7008
+ # (we've reverted the upstream patch because it was worse
+ # than the original issue)
+ Tests/test_file_libtiff.py::TestFileLibTiff::test_exif_ifd
+ )
+ ;;
+ esac
+
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # leak tests are fragile and broken under xdist
+ epytest -k "not leak" -p timeout || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}