summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-04-29 08:56:14 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-06-10 10:48:23 +0200
commite484db6607f4e935f843e753af1ed8425b00547a (patch)
tree604bb44c732ea6aaf32cb40f537203c0fb22b302 /dev-python/pivy
parentgames-strategy/0ad: update nvtt description (diff)
downloadgentoo-e484db6607f4e935f843e753af1ed8425b00547a.tar.gz
gentoo-e484db6607f4e935f843e753af1ed8425b00547a.tar.bz2
gentoo-e484db6607f4e935f843e753af1ed8425b00547a.zip
dev-python/pivy: bump to 0.6.7
Add py3_11 support, enabling tests Closes: https://bugs.gentoo.org/849746 Bug: https://bugs.gentoo.org/835724 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/25823 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-python/pivy')
-rw-r--r--dev-python/pivy/Manifest1
-rw-r--r--dev-python/pivy/files/pivy-0.6.7-find-qmake.patch29
-rw-r--r--dev-python/pivy/pivy-0.6.7.ebuild59
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pivy/Manifest b/dev-python/pivy/Manifest
index 4c03580a9fd3..6ed1272ceb91 100644
--- a/dev-python/pivy/Manifest
+++ b/dev-python/pivy/Manifest
@@ -1 +1,2 @@
DIST pivy-0.6.6.tar.gz 6618471 BLAKE2B 5bcf2479bf26628e3dfe59c1440901368442de2f32a5680ef1af10d49239d8c73b79809495d7227937fd7784af1e1ded27f93f0255793e713add0c1cc35b8e5d SHA512 e260c6abd0aede7621d5fed66eeceb98a32634af84370ef713d70d583ec017cded4be682fd7e70e5faa19988a5e032a9d2f2308b8ae6dd9495d76e884de1d80c
+DIST pivy-0.6.7.tar.gz 6618410 BLAKE2B 22ebe63a75fa624b772cb3d3ff6f03336258f6c8b638613413c19fcea072f83f73396bc91d35f0e06bc27ec57471ae67965ee492e62a7e73919f7827de645175 SHA512 606eac3527b5906ad6884c25775b5625bfd2a1b1c78f75017b05e662d622c75d30e70fd5785ec2145902f5a02d99098b52cc776aee12fab02f0319762ee104b0
diff --git a/dev-python/pivy/files/pivy-0.6.7-find-qmake.patch b/dev-python/pivy/files/pivy-0.6.7-find-qmake.patch
new file mode 100644
index 000000000000..6332afa97a3c
--- /dev/null
+++ b/dev-python/pivy/files/pivy-0.6.7-find-qmake.patch
@@ -0,0 +1,29 @@
+https://github.com/gentoo/gentoo/pull/25823#issuecomment-1150748775
+
+From 2d654ef2837f2ca934f636fc8a63de47a9d5853d Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Thu, 9 Jun 2022 18:26:29 +0200
+Subject: [PATCH] find qmake
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/qtinfo.py
++++ b/qtinfo.py
+@@ -7,7 +7,7 @@ class QtInfo(object):
+ if qmake_command:
+ self._qmake_command = qmake_command
+ else:
+- self._qmake_command = [find_executable("qmake"),]
++ self._qmake_command = [find_executable("qmake5"),]
+ self._dict = {}
+ # bind all variables early at __init__ time.
+ for thing in self.__class__.__dict__:
+@@ -79,4 +79,4 @@ class QtInfo(object):
+ translations_dir = property(getTranslationsPath)
+ headers_dir = property(getHeadersPath)
+ docs_dir = property(getDocsPath)
+- qml_dir = property(getQmlPath)
+\ No newline at end of file
++ qml_dir = property(getQmlPath)
+--
+2.35.1
+
diff --git a/dev-python/pivy/pivy-0.6.7.ebuild b/dev-python/pivy/pivy-0.6.7.ebuild
new file mode 100644
index 000000000000..6c17df4c10c7
--- /dev/null
+++ b/dev-python/pivy/pivy-0.6.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Coin3D bindings for Python"
+HOMEPAGE="https://github.com/coin3d/pivy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ PIVY_REPO_URI="https://github.com/coin3d/pivy.git"
+else
+ SRC_URI="https://github.com/coin3d/pivy/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+quarter soqt test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( quarter soqt )
+"
+
+RDEPEND="
+ >=media-libs/coin-4.0.0
+ quarter? ( media-libs/quarter )
+ soqt? ( >=media-libs/SoQt-1.6.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cmake
+ test? ( ${RDEPEND} )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.6-0001-fix-CMakeLists.txt-for-distutils_cmake.patch
+ "${FILESDIR}"/${PN}-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
+ "${FILESDIR}"/${P}-find-qmake.patch
+)
+
+DOCS=( AUTHORS HACKING NEWS README.md THANKS )
+
+python_test() {
+ # visual_test.py is interactive
+ # pyside_test.py currently fails
+ # quarter_tests.py needs pyside2, which currently lacks py3_11 support
+ for f in tests/coin_tests.py; do
+ "${EPYTHON}" "${f}" || die "Test ${f} failed with ${EPYTHON}"
+ done
+}