summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-18 19:50:23 -0500
committerSam James <sam@gentoo.org>2021-01-22 03:56:42 +0000
commitb75e5e2e169d9c492245662ac9fc5cdcf029898a (patch)
treefa2caf7e4d54f8ee430c074f892dae10307c696b /dev-python/plotly/plotly-4.14.3.ebuild
parentmail-client/mutt-wizard: drop commit based old version (diff)
downloadgentoo-b75e5e2e169d9c492245662ac9fc5cdcf029898a.tar.gz
gentoo-b75e5e2e169d9c492245662ac9fc5cdcf029898a.tar.bz2
gentoo-b75e5e2e169d9c492245662ac9fc5cdcf029898a.zip
dev-python/plotly: version bump to 4.14.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/19120 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/plotly/plotly-4.14.3.ebuild')
-rw-r--r--dev-python/plotly/plotly-4.14.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/plotly/plotly-4.14.3.ebuild b/dev-python/plotly/plotly-4.14.3.ebuild
new file mode 100644
index 000000000000..8ad2011ab482
--- /dev/null
+++ b/dev-python/plotly/plotly-4.14.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/retrying[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ mkdir -p "${ED}"/etc/ || die
+ mv "${ED}"/usr/etc/jupyter "${ED}"/etc/ || die
+ rmdir "${ED}"/usr/etc || die
+}