summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-21 04:28:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-21 04:35:06 +0200
commit58d64b07f5199c3f646be1b07c1e76e91c8f5f77 (patch)
tree5040a67507c227f6bae4411d8264c42d59d9f604 /dev-python/pluggy
parentdev-python/pyicu: Bump to 2.13 (diff)
downloadgentoo-58d64b07f5199c3f646be1b07c1e76e91c8f5f77.tar.gz
gentoo-58d64b07f5199c3f646be1b07c1e76e91c8f5f77.tar.bz2
gentoo-58d64b07f5199c3f646be1b07c1e76e91c8f5f77.zip
dev-python/pluggy: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-1.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index 851b18929985..75d4a2669bd3 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-1.4.0.tar.gz 65812 BLAKE2B 0a8bff68f1871f0e571105012b0e3961771c6ee34a64711520084d0a951308d192187d01b14136c389b5bc09f127ead1a1f96ebffa7b345d2d5023157c049c43 SHA512 ac21a0c68cfcb9c7c401e5c48404f7447489b75befe8bc8b6e7ea84f24a1c6dbfb3de024577dd9e36ca9f538f9867ef836ba13018e3b8b348bba3e9bbd0c4dfd
+DIST pluggy-1.5.0.tar.gz 67955 BLAKE2B c63e7605b7631adf7fe3a91dae92d2ce8172510574e0b23ded159479077f91c88948487a7a4e1da30dca7da0339cb78fbb521538e67bc2bde37986970403d48f SHA512 032d41e1f2bed56eff22463c4645516e9415ee253e0a3fe5ba83a8de5e21700baae1f6384c979d2c6f622e4216a2b745eec489bc04f52a576d423e771365cc7a
diff --git a/dev-python/pluggy/pluggy-1.5.0.ebuild b/dev-python/pluggy/pluggy-1.5.0.ebuild
new file mode 100644
index 000000000000..bb57bffff542
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin and hook calling mechanisms for Python"
+HOMEPAGE="
+ https://pluggy.readthedocs.io/
+ https://github.com/pytest-dev/pluggy/
+ https://pypi.org/project/pluggy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest