summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-06 19:50:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-06 20:00:06 +0300
commita54485d4c570da258806451b65503593d9897cbe (patch)
tree8f8dcfe9c32160b58a8372688c2d4e48bd331682 /dev-python/plumbum
parentdev-python/caldav: add 0.9.2 (diff)
downloadgentoo-a54485d4c570da258806451b65503593d9897cbe.tar.gz
gentoo-a54485d4c570da258806451b65503593d9897cbe.tar.bz2
gentoo-a54485d4c570da258806451b65503593d9897cbe.zip
dev-python/plumbum: add 1.8.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest1
-rw-r--r--dev-python/plumbum/plumbum-1.8.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index f90c5ed59283..3aa20f7e8d56 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1 +1,2 @@
DIST plumbum-1.7.2.tar.gz 323051 BLAKE2B a16d9210606ac67abd425fcff109d40836dc969729cc5bf78a5d224c0beabf09d56d35f17809994d758153c6e18e4af91403f7ae0111912447367be68f6592c1 SHA512 77e75988255ca78fa5c253c6d076d63f8f9250a2b153ef23e40f35315e255ea09403d854a19bb265fd658bb9e5f0f705dc7530ecacc40b4b48e33acdf50dddf9
+DIST plumbum-1.8.0.tar.gz 325060 BLAKE2B 30006fa3826bbdd9482592d825931fd7dcb05b2aca6d762093c4f722f0426aaa6f07fde55754f115e4fba4a45997d2995a657c5a1cfa34c417bb4f5fb2e5834d SHA512 47874c42081d385fad85b9073fbeb711112b8fa847fc79035be1277a1fdabcfb06e7822a4dbba271d86502b9b297a70742f30b1158c363b668a47e783c9990cd
diff --git a/dev-python/plumbum/plumbum-1.8.0.ebuild b/dev-python/plumbum/plumbum-1.8.0.ebuild
new file mode 100644
index 000000000000..972553e6d9ac
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+)
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}