summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-09 11:59:36 -0800
committerTim Harder <radhermit@gentoo.org>2018-03-10 18:05:55 -0800
commitf0c867ddc8ce438e8da68b200b69ffb372f0ade1 (patch)
tree47855f3facbd9092acff4f4bb4a630e64b297af0 /dev-python/polib
parentprofiles/arch/hppa: Mask USE=iscsi (diff)
downloadgentoo-f0c867ddc8ce438e8da68b200b69ffb372f0ade1.tar.gz
gentoo-f0c867ddc8ce438e8da68b200b69ffb372f0ade1.tar.bz2
gentoo-f0c867ddc8ce438e8da68b200b69ffb372f0ade1.zip
dev-python/polib: version bump to 1.1.0
Diffstat (limited to 'dev-python/polib')
-rw-r--r--dev-python/polib/Manifest1
-rw-r--r--dev-python/polib/polib-1.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/polib/Manifest b/dev-python/polib/Manifest
index bb909a56294f..34f53c7909df 100644
--- a/dev-python/polib/Manifest
+++ b/dev-python/polib/Manifest
@@ -1,2 +1,3 @@
DIST polib-1.0.4.tar.gz 151634 BLAKE2B d0f28ae50e1c082f695867da2b65721d161b9df56b4978feda59388b20fee3c3a060438aac0f1f08420d5133d1b5425715a3c0cb00dffe0e7515d642e287d2cf SHA512 a38d57acdaded0371be83825a28f14f178aebdbc0435724f33eebda109adb2b8210e33659ebec88d2d9e98aa60c482d7f8a958ec18f6769fda7a2fb14edd2744
DIST polib-1.0.7.tar.gz 156282 BLAKE2B 4d4a9f9901fe7b7b7aa5fc54b9391e051b8d02d1749752e1c9a563d9285670db5d43d7c5015fe266f78c89d1ff7a334bd2afe2d7d8b68fb376df35f8902cb0ed SHA512 bfec3538f9ab499ff2149bb40e0685b4cb6d5f0bc7ce8dc33e1fc511a6169e01c1a317e652daed7b3bfd9bbfe6ee1d545b4d8913f54e91504c4debb5b1b94b6e
+DIST polib-1.1.0.tar.gz 158484 BLAKE2B 41766f00e3928eacf3c98406b6acce224f0d0cb44d79326c834db900ed8b91181911ab7e26845a737057dd07c067a784d0b06278952708c17888db42d8c1e303 SHA512 74681585b4d7252e107acd7d73f49f7e91c90adcd180722d39d35c40ec158434798af0124a16788cf564c73b84f52a040aefeb58355a1a3cd85848c3f6a5e67f
diff --git a/dev-python/polib/polib-1.1.0.ebuild b/dev-python/polib/polib-1.1.0.ebuild
new file mode 100644
index 000000000000..ae58824f7b11
--- /dev/null
+++ b/dev-python/polib/polib-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}