summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2019-12-18 22:02:20 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2019-12-18 22:04:16 +0000
commit7377e74536a257675e455b6857aba9941a6fa0d0 (patch)
tree4b503fc6cb2025cd20b7ab8f4f79e62cb9e637da /dev-python/precis-i18n
parentmedia-tv/kodi: Cleanup old version (diff)
downloadgentoo-7377e74536a257675e455b6857aba9941a6fa0d0.tar.gz
gentoo-7377e74536a257675e455b6857aba9941a6fa0d0.tar.bz2
gentoo-7377e74536a257675e455b6857aba9941a6fa0d0.zip
dev-python/precis-i18n: Bump version and enable Python 3.7 and 3.8
Upstream doesn't advertise 3.7 and 3.8 support but hanno confirmed it's working. Bug: https://bugs.gentoo.org/702232 Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org> Package-Manager: Portage-2.3.76, Repoman-2.3.16
Diffstat (limited to 'dev-python/precis-i18n')
-rw-r--r--dev-python/precis-i18n/Manifest1
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.0.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
index ba8ebfe0e039..3ffffd040755 100644
--- a/dev-python/precis-i18n/Manifest
+++ b/dev-python/precis-i18n/Manifest
@@ -1 +1,2 @@
DIST precis_i18n-1.0.0.tar.gz 61251 BLAKE2B 3f49f77ae4e6eea6ac1429a8de9b4ebe217d4d901edc223ee487d8a11bb45dc9e21a1e9fef9bd4478273ae721b5c02e4e2a7d2a3f28da281fcbdc17a12a1094e SHA512 9017852fdd2a066b8e31521bd39843f3b1f87259ce87e1567cfaa2b932b52b745ad84eb89b77a4c3ea0a04e513573655266b2cc73997e951268646da7a000e5d
+DIST precis_i18n-1.0.1.tar.gz 63941 BLAKE2B ee429304f41fd225b306d6df342e1ab62a9dcc3daa40ae08c88a02809230d7e356090c3414136799b176b74debfd901863cb673b577b336784411ca5baf3e92c SHA512 d8aaf99bbf3bde148f173ac8ffa5cab5051ec873d53e19336171dcd29f995e706746e5969d37aef05b6c9db064ca5e7b3944ae049b0a41e605e71a854248251b
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.1.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.1.ebuild
new file mode 100644
index 000000000000..9bb52d072570
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.python.org/pypi/precis-i18n"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}