summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-11 07:05:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-11 07:51:47 +0200
commit8d8b00b2c7935f91b1a0cbc5bd8dcee882e27180 (patch)
treea13522763076ea5529a6894a21ce6369770c4d72 /dev-python/prometheus-client
parentdev-python/braintree: Bump to 4.21.0 (diff)
downloadgentoo-8d8b00b2c7935f91b1a0cbc5bd8dcee882e27180.tar.gz
gentoo-8d8b00b2c7935f91b1a0cbc5bd8dcee882e27180.tar.bz2
gentoo-8d8b00b2c7935f91b1a0cbc5bd8dcee882e27180.zip
dev-python/prometheus-client: Bump to 0.17.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus-client')
-rw-r--r--dev-python/prometheus-client/Manifest1
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.17.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/prometheus-client/Manifest b/dev-python/prometheus-client/Manifest
index dc3ec0104d92..afe4cf03384a 100644
--- a/dev-python/prometheus-client/Manifest
+++ b/dev-python/prometheus-client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.17.0.tar.gz 90650 BLAKE2B 04bc44e930c94edc9fb0ceb5cc5be71cbec23435d271ec63acacbb10b42b192170ed7f92c767a575a08a8140d9cfc28b591c49ad9af2e6d931990daba45637ba SHA512 da9a27a514dca0ae2721eaa607c5adfa86686553eebc0c4eb4323d0866d03b520de5085b8e39560df0525ef3bbbbc7996271b64136f60a427fb14fb8851e595f
+DIST prometheus_client-0.17.1.tar.gz 90360 BLAKE2B 3927d5b6829a04cd72a99ac3b0b6a12726865b41d17f165a53f83a6a3791f18e25e03995088152ac7eae016eab7c6e29bef1e605f4c444f9963be04483ca2f02 SHA512 c8c776d646ea4a18a85fd26c858158b67979173dcf52d0a337cdb87fe907ff4081d8e0771176ba8be0ea6e244ee9b9097396c9aeb6f6db170a2c0f5a4898c771
diff --git a/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild b/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild
new file mode 100644
index 000000000000..4c7172a015c2
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest