summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 22:53:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 23:18:07 +0200
commitda32793999c21e305b30732d8b11538514cb6527 (patch)
tree5d105aabff04f50677df047b294f6c30553709ad /dev-python/prometheus_client
parentdev-python/graphviz: Bump to 0.19.2 (diff)
downloadgentoo-da32793999c21e305b30732d8b11538514cb6527.tar.gz
gentoo-da32793999c21e305b30732d8b11538514cb6527.tar.bz2
gentoo-da32793999c21e305b30732d8b11538514cb6527.zip
dev-python/prometheus_client: Bump to 0.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.14.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index c1268c0ab579..33fb685b2af2 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,2 +1,3 @@
DIST prometheus_client-0.13.1.gh.tar.gz 73480 BLAKE2B 53b2572373024a452731c055fc115ddb3c029b905d455cf9dc6289af91866c13187e58008770aa20969b371cd0852ef20651603e153195fb4658d21a628df5a3 SHA512 8d5263ff00fc4797fa65a446bdab4dc3c717cc091f8cee571fdd2130febc480cc61e73e11145ac2bf9bc0eee132efc92d88a4d4facd61d515234748791a92255
DIST prometheus_client-0.14.0.gh.tar.gz 76115 BLAKE2B 08cffa53fd97be8ee48e91b69f1091ac52179fb48f2001aea23755e0ffd2e09cb34d97f052b0f38762bbe1f6597aed9bc630cda393bf5cd2f723dcb939f2471a SHA512 6543756b7fcd4b4a1734397c3fc25b14e00c9910133afc89f9836591e554c73a4a9fa4f3bc14b4fca2c922b6c160c769a4da435b337d0709f1884bde67008f7e
+DIST prometheus_client-0.14.1.gh.tar.gz 76321 BLAKE2B fd924e80d32df9fceb8898530893148f3f1131a13e97a3bac56540ba2fe3846c5498bb78d3cdcb312827dd8a8db2624e831880c5c1f348da0522db96dd0ef29e SHA512 882e7193cb344d154df8a7b7fbdfb5c635363c1aea8bde1ea174a7614bc868fe337399db7a1fb90a94128d7bdfedbc741f5f6c44d514d1ca9ab684c7527e7317
diff --git a/dev-python/prometheus_client/prometheus_client-0.14.1.ebuild b/dev-python/prometheus_client/prometheus_client-0.14.1.ebuild
new file mode 100644
index 000000000000..4c182f58d21a
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.14.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://pypi.org/project/prometheus-client/
+ https://github.com/prometheus/client_python/
+"
+SRC_URI="
+ https://github.com/prometheus/client_python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/client_python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest