summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarshall Brewer <tomboy64@sina.cn>2016-06-03 19:51:03 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-23 15:25:29 +0000
commit9bdeb0e7b787a98be60d0c57361557679a2a4fbf (patch)
tree24a4ceb41d1f771bf6af127291560b078a60c167 /dev-python/protobuf-python/files
parentdev-java/protobuf-java: version bump 3.0.0_beta3 (diff)
downloadgentoo-9bdeb0e7b787a98be60d0c57361557679a2a4fbf.tar.gz
gentoo-9bdeb0e7b787a98be60d0c57361557679a2a4fbf.tar.bz2
gentoo-9bdeb0e7b787a98be60d0c57361557679a2a4fbf.zip
dev-python/protobuf-python: version bump 3.0.0_beta3
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1603 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python/files')
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.0.0_beta2-link-against-installed-lib.patch (renamed from dev-python/protobuf-python/files/protobuf-3.0.0_beta2-link-against-installed-lib.patch)0
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch33
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/files/protobuf-3.0.0_beta2-link-against-installed-lib.patch b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta2-link-against-installed-lib.patch
index 3d419ba3d194..3d419ba3d194 100644
--- a/dev-python/protobuf-python/files/protobuf-3.0.0_beta2-link-against-installed-lib.patch
+++ b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta2-link-against-installed-lib.patch
diff --git a/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
new file mode 100644
index 000000000000..cb4a5f6cf7eb
--- /dev/null
+++ b/dev-python/protobuf-python/files/protobuf-python-3.0.0_beta3-link-against-installed-lib.patch
@@ -0,0 +1,33 @@
+diff -Naur python/setup.py python/setup.py
+--- python/setup.py 2015-12-30 22:21:46.000000000 +0100
++++ python/setup.py 2016-04-18 00:51:49.490809789 +0200
+@@ -190,15 +190,27 @@
+ extra_compile_args.append('-Werror')
+ sys.argv.remove(warnings_as_errors)
+
++ inclD = ['.', '../src']
++ libD = []
++ try:
++ subprocess.check_call(['pkg-config', '--exists', 'protobuf'])
++ inclD += subprocess.check_output(['pkg-config','--variable=includedir','protobuf']).split()
++ libD = subprocess.check_output(['pkg-config','--variable=libdir','protobuf']).split()
++ except OSError as osex:
++ if osex.errno == errno.ENOENT:
++ info('pkg-config not found')
++ else:
++ warn("Running pkg-config failed - %s." % osex)
++ libD = ['../src/.libs']
+ # C++ implementation extension
+ ext_module_list.extend([
+ Extension(
+ "google.protobuf.pyext._message",
+ glob.glob('google/protobuf/pyext/*.cc'),
+- include_dirs=[".", "../src"],
++ include_dirs=inclD,
+ libraries=libraries,
+ extra_objects=extra_objects,
+- library_dirs=['../src/.libs'],
++ library_dirs=libD,
+ extra_compile_args=extra_compile_args,
+ ),
+ Extension(