summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-05 18:22:15 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 00:18:55 +0100
commit1a92efef72a342ac4eff966327b7cf8adc686e64 (patch)
tree16410e498dd9d0da29a251484ba650a225ce91b3 /dev-python/protobuf-python
parentdev-python/progressbar: Clean old up (diff)
downloadgentoo-1a92efef72a342ac4eff966327b7cf8adc686e64.tar.gz
gentoo-1a92efef72a342ac4eff966327b7cf8adc686e64.tar.bz2
gentoo-1a92efef72a342ac4eff966327b7cf8adc686e64.zip
dev-python/protobuf-python: Clean old up
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest1
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.3.0-r1.ebuild46
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.3.0.ebuild39
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index 1b446733fb6a..2cf0bd71c2d4 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1,3 +1,2 @@
DIST protobuf-3.1.0.tar.gz 4051503 BLAKE2B af93f125a6b7b3e0be6f50ff5eaabe0db21f62b01a694d37c0b069956ef5d658df1beef68514b00a22005a36293b4a8a18654b5656f8c614309f0a744039c2fb SHA512 8d3289a16944c255bd1cceab696e515e52467f2bfe1cc10f6b32fabdf082d5acdc248ec9cadc572223a24d04d431f75921076153109cea2f90ee533f502ab47a
-DIST protobuf-3.3.0.tar.gz 4336596 BLAKE2B 381b2961fe1de8a86225903d0cfe4c98c238336b8782e5191c57c6fcf60cf321f39163d50864bf9c119a90bd7796269dc7e34168a158f7affa7fa295ce5deae0 SHA512 0734a55ae92f0539dfb507e174539d290fd8e93633c1edd8810e0d51c37e67254337b75fc5ba9450316f6416e1f8f8cfb59415864657b55f2a1696fbcdfe7636
DIST protobuf-3.4.1.tar.gz 4490100 BLAKE2B e2bc1ef2ee1a0af44830b3c65a6c9e73883fe6ec0d07f6a6136f5564f0e85306005440ca6f8c4eb834c7c70f909792c9e2457a761f10f95431981263a9acd7a3 SHA512 471e52198fa878a79183dc8fbc39d9c65239be4d9dff799e12281ee9b1af61a427584534b1baae1773bc6e4c86467f89ca2e7911a21effd86bc5f40cc7d94c34
diff --git a/dev-python/protobuf-python/protobuf-python-3.3.0-r1.ebuild b/dev-python/protobuf-python/protobuf-python-3.3.0-r1.ebuild
deleted file mode 100644
index a70b39fe2bc7..000000000000
--- a/dev-python/protobuf-python/protobuf-python-3.3.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-# pypy fails tests; pypy3 fails even running tests
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_beta/-beta-}
-MY_PV=${MY_PV/_p/.}
-
-DESCRIPTION="Google's Protocol Buffers - official Python bindings"
-HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
-SRC_URI="https://github.com/google/protobuf/archive/v${MY_PV}.tar.gz -> protobuf-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/13"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-# Protobuf is only a build-time dep, but depends on the exact same version
-# (excluding revision), since we are using the same tarball.
-# In case of using the (linked) cpp implementation we should be fine with the same subslot.
-RDEPEND="${PYTHON_DEPS}
- dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !<dev-libs/protobuf-3[python(-)]
- ~dev-libs/protobuf-${PV}"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}/${PN}-3.0.0_beta3-link-against-installed-lib.patch" )
-
-S="${WORKDIR}/protobuf-${MY_PV}/python"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/protobuf-python/protobuf-python-3.3.0.ebuild b/dev-python/protobuf-python/protobuf-python-3.3.0.ebuild
deleted file mode 100644
index c3076f1f5b6d..000000000000
--- a/dev-python/protobuf-python/protobuf-python-3.3.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-# pypy fails tests; pypy3 fails even running tests
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_beta/-beta-}
-MY_PV=${MY_PV/_p/.}
-
-DESCRIPTION="Google's Protocol Buffers - official Python bindings"
-HOMEPAGE="https://github.com/google/protobuf/ https://developers.google.com/protocol-buffers/"
-SRC_URI="https://github.com/google/protobuf/archive/v${MY_PV}.tar.gz -> protobuf-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/13"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-# Protobuf is only a build-time dep, but depends on the exact same version
-# (excluding revision), since we are using the same tarball.
-# In case of using the (linked) cpp implementation we should be fine with the same subslot.
-RDEPEND="${PYTHON_DEPS}
- !<dev-libs/protobuf-3[python(-)]
- ~dev-libs/protobuf-${PV}"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}/${PN}-3.0.0_beta3-link-against-installed-lib.patch" )
-
-S="${WORKDIR}/protobuf-${MY_PV}/python"
-
-python_test() {
- esetup.py test
-}