summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-10-02 21:50:26 +0200
committerMike Gilbert <floppym@gentoo.org>2018-10-02 16:07:26 -0400
commit75e0f119f85b8115b69e74a24b27b50df527f9cd (patch)
treefb6af577e4a0721e4bfe06729e587fcefa3b40a2 /dev-python/protobuf-python
parentdev-python/namespace-google: Support Python 3.7. (diff)
downloadgentoo-75e0f119f85b8115b69e74a24b27b50df527f9cd.tar.gz
gentoo-75e0f119f85b8115b69e74a24b27b50df527f9cd.tar.bz2
gentoo-75e0f119f85b8115b69e74a24b27b50df527f9cd.zip
dev-python/protobuf-python: Support Python 3.7.
Closes: https://bugs.gentoo.org/664508 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.6.1-python-3.7.patch67
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.6.1.ebuild3
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/protobuf-python/files/protobuf-python-3.6.1-python-3.7.patch b/dev-python/protobuf-python/files/protobuf-python-3.6.1-python-3.7.patch
new file mode 100644
index 000000000000..bd4ce9d7fcaf
--- /dev/null
+++ b/dev-python/protobuf-python/files/protobuf-python-3.6.1-python-3.7.patch
@@ -0,0 +1,67 @@
+https://github.com/protocolbuffers/protobuf/pull/4862
+https://github.com/protocolbuffers/protobuf/commit/0a59054c30e4f0ba10f10acfc1d7f3814c63e1a7
+
+--- /python/google/protobuf/pyext/descriptor.cc
++++ /python/google/protobuf/pyext/descriptor.cc
+@@ -56,7 +56,7 @@
+ #endif
+ #define PyString_AsStringAndSize(ob, charpp, sizep) \
+ (PyUnicode_Check(ob)? \
+- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
++ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
+ PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
+ #endif
+
+--- /python/google/protobuf/pyext/descriptor_containers.cc
++++ /python/google/protobuf/pyext/descriptor_containers.cc
+@@ -66,7 +66,7 @@
+ #endif
+ #define PyString_AsStringAndSize(ob, charpp, sizep) \
+ (PyUnicode_Check(ob)? \
+- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
++ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
+ PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
+ #endif
+
+--- /python/google/protobuf/pyext/descriptor_pool.cc
++++ /python/google/protobuf/pyext/descriptor_pool.cc
+@@ -48,7 +48,7 @@
+ #endif
+ #define PyString_AsStringAndSize(ob, charpp, sizep) \
+ (PyUnicode_Check(ob)? \
+- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
++ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
+ PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
+ #endif
+
+--- /python/google/protobuf/pyext/extension_dict.cc
++++ /python/google/protobuf/pyext/extension_dict.cc
+@@ -53,7 +53,7 @@
+ #endif
+ #define PyString_AsStringAndSize(ob, charpp, sizep) \
+ (PyUnicode_Check(ob)? \
+- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
++ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
+ PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
+ #endif
+
+--- /python/google/protobuf/pyext/message.cc
++++ /python/google/protobuf/pyext/message.cc
+@@ -79,7 +79,7 @@
+ (PyUnicode_Check(ob)? PyUnicode_AsUTF8(ob): PyBytes_AsString(ob))
+ #define PyString_AsStringAndSize(ob, charpp, sizep) \
+ (PyUnicode_Check(ob)? \
+- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
++ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
+ PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
+ #endif
+ #endif
+@@ -1529,7 +1529,7 @@
+ return NULL;
+ }
+ #else
+- field_name = PyUnicode_AsUTF8AndSize(arg, &size);
++ field_name = const_cast<char*>(PyUnicode_AsUTF8AndSize(arg, &size));
+ if (!field_name) {
+ return NULL;
+ }
diff --git a/dev-python/protobuf-python/protobuf-python-3.6.1.ebuild b/dev-python/protobuf-python/protobuf-python-3.6.1.ebuild
index d2f29ce98df9..3d8397734fcd 100644
--- a/dev-python/protobuf-python/protobuf-python-3.6.1.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-3.6.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
inherit distutils-r1
@@ -27,6 +27,7 @@ S="${WORKDIR}/protobuf-${PV}/python"
python_prepare_all() {
eapply -p2 "${FILESDIR}/${PN}-3.5.2-google.protobuf.pyext._message.MessageMeta.patch"
+ eapply -p2 "${FILESDIR}/${PN}-3.6.1-python-3.7.patch"
distutils-r1_python_prepare_all
}