summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-18 22:15:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-18 22:40:24 +0200
commit9d223fccd11a41f2c081c12a5d846a4e330b44e6 (patch)
tree7e60fa8619f7c8606e107ca9406899f4c2f58b61 /dev-python/pycares
parentdev-python/importlib_resources: Bump to 5.3.0 (diff)
downloadgentoo-9d223fccd11a41f2c081c12a5d846a4e330b44e6.tar.gz
gentoo-9d223fccd11a41f2c081c12a5d846a4e330b44e6.tar.bz2
gentoo-9d223fccd11a41f2c081c12a5d846a4e330b44e6.zip
dev-python/pycares: Bump to 4.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-4.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 710985571295..6b8ea4e9a3b7 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1 +1,2 @@
DIST pycares-4.0.0.tar.gz 43512 BLAKE2B cccfd5738582da570a2b9b17e6e31764ff2fffe4306f08c09374707a8e1c997ca7bdf0c867252c6ec66712622c927989c4d8bcad42075c48cb2af0a5364908e8 SHA512 796f14fb13c5e848b98459287d9658e8d81a48b2b6e08793f794bf9bcf7381bd400f43a07b50b23c4578579098dab5954beae09f8d35da7b809552f701d03b05
+DIST pycares-4.1.2.tar.gz 43668 BLAKE2B 4b26f8643ff5ce297981b0b60b3afb34b249138e8f702dd4aa0a38935e9e5338d048f3be1b4fb64d6d8b2259a279a8881dbd44b412c10427dbd7eee664e70495 SHA512 6fb2d24fb5f2638c55424608b02ebe9f630866d644decfb663ab9d8e2bb7a42629748fa220054747f9c36ce3dcb42f3b8e457c5c39009f94b564ff07efde0c84
diff --git a/dev-python/pycares/pycares-4.1.2.ebuild b/dev-python/pycares/pycares-4.1.2.ebuild
new file mode 100644
index 000000000000..c24fe865ba50
--- /dev/null
+++ b/dev-python/pycares/pycares-4.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="https://github.com/saghul/pycares/archive/${P/_p/-fix}.tar.gz"
+S=${WORKDIR}/${PN}-${P/_p/-fix}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="net-dns/c-ares"
+BDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}"
+BDEPEND+="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )"
+
+export PYCARES_USE_SYSTEM_LIB=1
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}