summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-13 07:13:04 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-13 08:08:52 +0100
commit69f168578c0234732939c8ecb6ea38078e8ef9e4 (patch)
tree0a04540e03d2ca8ddd0edd9eabec2e150eb756df /dev-python/pyfakefs
parentdev-python/Faker: Bump to 16.4.0 (diff)
downloadgentoo-69f168578c0234732939c8ecb6ea38078e8ef9e4.tar.gz
gentoo-69f168578c0234732939c8ecb6ea38078e8ef9e4.tar.bz2
gentoo-69f168578c0234732939c8ecb6ea38078e8ef9e4.zip
dev-python/pyfakefs: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.1.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 040291ed432b..3117f1c86cad 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1 +1,2 @@
DIST pyfakefs-5.0.0.gh.tar.gz 211213 BLAKE2B 79b83e0a07b094727a0e8d869c99ca64e132f1b7e81202fccad2b4a34871e86630defb87bb5bcfd638a59908c5fdf230aa0cc1e2e3b8393259374a6c5087db90 SHA512 e7125d3b9b186d121bc0b0dba5acf27afe405a6e2a4d8152008450f83a65918b1f612e479ab56c065542dd070b84aeb97cd281123636c062981873d94e4d935a
+DIST pyfakefs-5.1.0.gh.tar.gz 212507 BLAKE2B b9607ff2af71d6697bb5ea5ceae0bb1b92b9aa2e91bafdf24d3dab6f5412a6fd8ff590983085079e9a7b1569b839f4fc5b443d5904decf2de5511ab856e8de7d SHA512 40d4e3fb422c2d9515c00bfa9940a8799d5e102a5775ac34d45e99286759451d1287df1e32f45956a84c1052cc02eed98a8f9789a628ac253771042b011ddd3e
diff --git a/dev-python/pyfakefs/pyfakefs-5.1.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.1.0.ebuild
new file mode 100644
index 000000000000..a48afea766e6
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}