summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 18:31:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 18:43:52 +0100
commit159a743f8d3e0e8ac32f6481f3449b71963ec3f8 (patch)
treeafba349da3231418866ba23e793f2138550c320e /dev-python/pygame
parentdev-python/pyformance: Remove redundant versions (diff)
downloadgentoo-159a743f8d3e0e8ac32f6481f3449b71963ec3f8.tar.gz
gentoo-159a743f8d3e0e8ac32f6481f3449b71963ec3f8.tar.bz2
gentoo-159a743f8d3e0e8ac32f6481f3449b71963ec3f8.zip
dev-python/pygame: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/Manifest1
-rw-r--r--dev-python/pygame/pygame-1.9.3.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/pygame/Manifest b/dev-python/pygame/Manifest
index 4740c1c3f0c9..b3ae74d328f3 100644
--- a/dev-python/pygame/Manifest
+++ b/dev-python/pygame/Manifest
@@ -1,2 +1 @@
-DIST pygame-1.9.3.tar.gz 2974541 BLAKE2B 38ba1f85d845cf33202819705ad564168fb3bc7041731d50d8c3f6bf1c55bebf41202f8ae9e4c4ba52cabe7335a9df13d7724104015b49842dc7f7aa7b0bfd19 SHA512 8920c598a97b4ff8602391517f070b67263bacb6330e13ea5d7d5432ee592a7c984fe986837b90a032da3d4e717f9df0cc99f0fb39f1cbde1b4f6a4c132feffe
DIST pygame-1.9.6.tar.gz 3223131 BLAKE2B a4d04c933fcad244d32bd512ef8717e60ec923f361e9e0296b5c7d57c5949d3434a040d028249c5b8f3c865ac3dcdbb32e6f0b223186678595a8625213ba2a17 SHA512 d923c554203a7c35e37921658cb4c5bf50215ab0ff4d2b869a1ee6b2e2ca31d66ec4bbde4287f5a777838ffe932cd15b993cb0224b86e43d684de61c35acbcd0
diff --git a/dev-python/pygame/pygame-1.9.3.ebuild b/dev-python/pygame/pygame-1.9.3.ebuild
deleted file mode 100644
index 771b5b844792..000000000000
--- a/dev-python/pygame/pygame-1.9.3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
-DISTUTILS_IN_SOURCE_BUILD=1
-inherit flag-o-matic distutils-r1 virtualx
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~sparc x86"
-IUSE="doc examples midi X"
-
-DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=media-libs/sdl-image-1.2.2[png,jpeg]
- >=media-libs/sdl-mixer-1.2.4
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/smpeg-0.4.4-r1
- midi? ( media-libs/portmidi )
- X? ( >=media-libs/libsdl-1.2.5[X,video] )
- !X? ( >=media-libs/libsdl-1.2.5 )"
-RDEPEND="${DEPEND}"
-
-DOCS=( WHATSNEW )
-
-# various module import and data path issues
-RESTRICT=test
-
-python_configure() {
- PORTMIDI_INC_PORTTIME=1 LOCALBASE="${EPREFIX}/usr" "${EPYTHON}" config.py -auto
-
- if ! use X; then
- sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
- fi
-
- # Disable automagic dependency on PortMidi.
- if ! use midi; then
- sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
- fi
-}
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
-
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- PYTHONPATH="${BUILD_DIR}/lib" virtx "${EPYTHON}" -m pygame.tests
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Bug #497720
- rm -fr "${D}"$(python_get_sitedir)/pygame/{docs,examples,tests}/ || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use doc; then
- docinto html
- dodoc -r docs/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}