summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-08-08 09:42:49 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-08 09:50:55 +0200
commit4326abaaa1865ac44dbca4b97250c51181bad2d9 (patch)
tree94a095c35673069cd39274954822854b9fa0ca8e /dev-python/pyinsane/pyinsane-2.0.13.ebuild
parentsys-cluster/pconsole: remove old (diff)
downloadgentoo-4326abaaa1865ac44dbca4b97250c51181bad2d9.tar.gz
gentoo-4326abaaa1865ac44dbca4b97250c51181bad2d9.tar.bz2
gentoo-4326abaaa1865ac44dbca4b97250c51181bad2d9.zip
dev-python/pyinsane: 2.0.13 bump
Update EAPI and python versions Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/pyinsane/pyinsane-2.0.13.ebuild')
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyinsane/pyinsane-2.0.13.ebuild b/dev-python/pyinsane/pyinsane-2.0.13.ebuild
new file mode 100644
index 000000000000..5048615b8a4d
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN}2"
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/openpaperwork/pyinsane"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}