summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-06 03:46:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-06 04:02:37 +0200
commite6e8e56d58cd498e268f5be45c80198f61cda511 (patch)
treed4c7b0b02f45e44d5c53c4b70dec262c9c0b81bb /dev-python/pylint
parentdev-python/ansible-compat: Bump to 24.6.1 (diff)
downloadgentoo-e6e8e56d58cd498e268f5be45c80198f61cda511.tar.gz
gentoo-e6e8e56d58cd498e268f5be45c80198f61cda511.tar.bz2
gentoo-e6e8e56d58cd498e268f5be45c80198f61cda511.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-3.1.1.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 7760911256d0..3054743c0b28 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-3.1.1.gh.tar.gz 1433456 BLAKE2B f51e253228b9bb2bddd2edac76c11ae1e5c712e755665bf3f808da832af313626037aded39eeb75941b7462a87668ea2de307740bd6a736d3130aa10850b5c9f SHA512 66a30a45a1ac816a1e2ff16ea774fb5b5d646f89645c8f551ab4a65feea3076e6bc1b54ff1b71e5d8586f344c02b0e85c9b34d2c5b0afba115fd92cb7cb0a3f1
DIST pylint-3.2.2.gh.tar.gz 1443983 BLAKE2B aeff52756e03278da1db7478d0c95ca0d5fa0c8a15203ada4b30fe5fb2fa56bfc2fc60e020bee9b2e242339214cf383838c93cbf1369a82655bedd62e3b2634f SHA512 84d625b0cd1ea0c308ff4381a9f553663af52fec534856a258ee50f00ec7238cf9af98d1e2c851522a8bd440c55e318d5c89035652d872cbd812d19ff14a0698
diff --git a/dev-python/pylint/pylint-3.1.1.ebuild b/dev-python/pylint/pylint-3.1.1.ebuild
deleted file mode 100644
index 1409078f2537..000000000000
--- a/dev-python/pylint/pylint-3.1.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_P=${P/_beta/b}
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/pylint-dev/pylint/
-"
-SRC_URI="
- https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-3.2[${PYTHON_USEDEP}]
- >=dev-python/astroid-3.1.0[${PYTHON_USEDEP}]
- >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- ' 'python*' )
- <dev-python/pytest-8[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- 'tests/test_functional.py::test_functional[recursion_error_3159]'
- 'tests/test_functional.py::test_functional[shadowed_import]'
- 'tests/test_functional.py::test_functional[use_yield_from]'
- 'tests/test_functional.py::test_functional[wrong_import_order]'
- )
- local EPYTEST_IGNORE=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
-
- if ! has_version "dev-python/GitPython[${PYTHON_USEDEP}]"; then
- EPYTEST_IGNORE+=(
- tests/profile/test_profile_against_externals.py
- tests/testutils/_primer/test_package_to_lint.py
- tests/testutils/_primer/test_primer.py
- )
- fi
-
- rm -rf pylint || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p timeout
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}