summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyml')
-rw-r--r--dev-python/pyml/Manifest2
-rw-r--r--dev-python/pyml/metadata.xml12
-rw-r--r--dev-python/pyml/pyml-0.7.13.2-r1.ebuild35
-rw-r--r--dev-python/pyml/pyml-0.7.13.3.ebuild35
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pyml/Manifest b/dev-python/pyml/Manifest
new file mode 100644
index 000000000000..e681cefad913
--- /dev/null
+++ b/dev-python/pyml/Manifest
@@ -0,0 +1,2 @@
+DIST PyML-0.7.13.2.tar.gz 5880930 SHA256 daec23fb3293d8d00efcbb64464676c196807a81a959e6adac5aceb08b15503b SHA512 8a642cfc8744098e145cf6940c606f53034c3a04aa9665e23bfd30bbd4098bcceaf10508ea9c3b3be40f1b9d964aea793c7e20d4b48eb66656b5fd6b200fca5c WHIRLPOOL 9adbf1b4a75627bf10e93fcea93b9ab60a128a0ec3523fdd3f9ff1a58b8df1a1501617b4684dd56a04c518bbecb13a34b48d41c529057c17477f665f09612879
+DIST PyML-0.7.13.3.tar.gz 5896911 SHA256 607c722d7ca309aa382ba1fc1c8580de11fa3ee4659aee11d4c2d2873fad6f77 SHA512 9933be07122e6fc7ece017b28fbc895cd2ef2778d8d5144c7f084ddd2090e054e37a581341371450fd7c28713ed4c725e229a81daad571150f476945750a51ae WHIRLPOOL f21ce9fe10dffdde92585750f3de4c33f14f5f67638590ffd92df909654c8224aa1d5ca1bbeaf1b529ceab94d595fe188439547a9f7478a94b332f9315a3cdd5
diff --git a/dev-python/pyml/metadata.xml b/dev-python/pyml/metadata.xml
new file mode 100644
index 000000000000..8457b7b53d6d
--- /dev/null
+++ b/dev-python/pyml/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ PyML is a flexible Python framework for using various classification
+ methods including Support Vector Machines (SVM).
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyml/pyml-0.7.13.2-r1.ebuild b/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
new file mode 100644
index 000000000000..a2208f1ecbfc
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ pushd data > /dev/null
+ "${PYTHON}" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}
diff --git a/dev-python/pyml/pyml-0.7.13.3.ebuild b/dev-python/pyml/pyml-0.7.13.3.ebuild
new file mode 100644
index 000000000000..a2208f1ecbfc
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.13.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ pushd data > /dev/null
+ "${PYTHON}" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}