summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pymountboot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pymountboot')
-rw-r--r--dev-python/pymountboot/Manifest2
-rw-r--r--dev-python/pymountboot/metadata.xml16
-rw-r--r--dev-python/pymountboot/pymountboot-0.2.1.ebuild20
-rw-r--r--dev-python/pymountboot/pymountboot-0.2.2.ebuild25
-rw-r--r--dev-python/pymountboot/pymountboot-9999.ebuild35
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/pymountboot/Manifest b/dev-python/pymountboot/Manifest
new file mode 100644
index 000000000000..a924642dea0b
--- /dev/null
+++ b/dev-python/pymountboot/Manifest
@@ -0,0 +1,2 @@
+DIST pymountboot-0.2.1.tar.bz2 4075 SHA256 0d3b109540380f92ae031b92e195f600165c6d45bf251ac83f82e9610df44406 SHA512 e21f73d832b69bc458a3f220f099bf6a8eabb21c0159b230969f4342e83874bac3983ef6bba19975b17e5185bdeb5cc42c6778f982f4fd4551a077039a2b6a0c WHIRLPOOL 1e644751e04cac4d3a6a1597cb8aaf3fc7e1031b45f269619fcd24f3feb3725364b94f9ee6fa6be26e5fbd5bf91bf94d15b025e6a933a65b014c7cf09b11b380
+DIST pymountboot-0.2.2.tar.bz2 4098 SHA256 d10a94069ee85c4038be7d600cc0ea0f97476a1798e962fb95510a17a018252f SHA512 bb6ec0772300b2edf9864a09ff64f67ad99f0cd29b009793e1b2a590be48146640c927b5772023d27e68fc2fba51652a55ab66d1cf875dd9b4134f043ac353c9 WHIRLPOOL 899180ddb16f65c12df18306fc093ebac694f060c9f183b610c4cb616e6a8c97e41813b07da0ba710aa6ae8923e0f22958af2f8830f3ce44b452172484f66a64
diff --git a/dev-python/pymountboot/metadata.xml b/dev-python/pymountboot/metadata.xml
new file mode 100644
index 000000000000..6d5d6440f942
--- /dev/null
+++ b/dev-python/pymountboot/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/pymountboot/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/pymountboot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymountboot/pymountboot-0.2.1.ebuild b/dev-python/pymountboot/pymountboot-0.2.1.ebuild
new file mode 100644
index 000000000000..60a9a161a48c
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-0.2.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/pymountboot/pymountboot-0.2.2.ebuild b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
new file mode 100644
index 000000000000..2367787847e3
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-0.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
diff --git a/dev-python/pymountboot/pymountboot-9999.ebuild b/dev-python/pymountboot/pymountboot-9999.ebuild
new file mode 100644
index 000000000000..5f8d95378f86
--- /dev/null
+++ b/dev-python/pymountboot/pymountboot-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+#if LIVE
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+inherit git-r3
+#endif
+
+DESCRIPTION="Python extension module to (re)mount /boot"
+HOMEPAGE="https://bitbucket.org/mgorny/pymountboot/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/util-linux-2.20"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}