summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyodbc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyodbc')
-rw-r--r--dev-python/pyodbc/Manifest1
-rw-r--r--dev-python/pyodbc/metadata.xml12
-rw-r--r--dev-python/pyodbc/pyodbc-3.0.7-r1.ebuild28
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyodbc/Manifest b/dev-python/pyodbc/Manifest
new file mode 100644
index 000000000000..c90f1ac660e2
--- /dev/null
+++ b/dev-python/pyodbc/Manifest
@@ -0,0 +1 @@
+DIST pyodbc-3.0.7.zip 85722 SHA256 d8355f2d43b10386070e8564aa973119fdb6e10864e1bbd73f3224cd3baab351 SHA512 35d4b17324c60f15bc8647961fff0fa74afa02e37e1019a399add468cfd96e0403f2f7259f3c0164e4c7cabce67de7c300c9950602d9293b0b94a84d2ed02ffe WHIRLPOOL 3da4ecf3706a7cfbe8f11e7f3b1891160e02f7331abea6b407cc5809faa8604f291163f3d3342d7bcf5daa54b1f95aca0b397a5412b7bcdb198810f4fcd59eff
diff --git a/dev-python/pyodbc/metadata.xml b/dev-python/pyodbc/metadata.xml
new file mode 100644
index 000000000000..cdef949fdd00
--- /dev/null
+++ b/dev-python/pyodbc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pyodbc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyodbc/pyodbc-3.0.7-r1.ebuild b/dev-python/pyodbc/pyodbc-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..ac95691f3098
--- /dev/null
+++ b/dev-python/pyodbc/pyodbc-3.0.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="python ODBC module to connect to almost any database"
+HOMEPAGE="http://code.google.com/p/pyodbc"
+SRC_URI="http://pyodbc.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="mssql"
+
+RDEPEND=">=dev-db/unixODBC-2.3.0
+ mssql? ( >=dev-db/freetds-0.64[odbc] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+ append-cxxflags -fno-strict-aliasing
+}